summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-05-21 01:54:48 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-05-21 01:54:48 +0000
commit7e76c827f827be3f5ba272cff7408384bf915039 (patch)
tree0f1c34b1775668fb47a6ce81e47bfbcc39fe3f5c /dev-php/php-cgi/php-cgi-4.4.0-r1.ebuild
parentRemove old-style PHP packages. (diff)
downloadhistorical-7e76c827f827be3f5ba272cff7408384bf915039.tar.gz
historical-7e76c827f827be3f5ba272cff7408384bf915039.tar.bz2
historical-7e76c827f827be3f5ba272cff7408384bf915039.zip
Remove old-style PHP packages.
Diffstat (limited to 'dev-php/php-cgi/php-cgi-4.4.0-r1.ebuild')
-rw-r--r--dev-php/php-cgi/php-cgi-4.4.0-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-php/php-cgi/php-cgi-4.4.0-r1.ebuild b/dev-php/php-cgi/php-cgi-4.4.0-r1.ebuild
deleted file mode 100644
index 24742722ec39..000000000000
--- a/dev-php/php-cgi/php-cgi-4.4.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.4.0-r1.ebuild,v 1.3 2005/10/29 22:16:13 chtekk Exp $
-
-PHPSAPI="cgi"
-inherit php-sapi eutils
-
-DESCRIPTION="PHP CGI"
-SLOT="0"
-IUSE="fastcgi force-cgi-redirect"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
-
-# for this revision only
-PDEPEND=">=${PHP_PROVIDER_PKG}-4.4.0"
-PROVIDE="${PROVIDE} virtual/httpd-php"
-
-src_unpack() {
- php-sapi_src_unpack
-}
-
-src_compile() {
- myconf="${myconf} --enable-cgi --disable-cli"
-
- if use fastcgi; then
- myconf="${myconf} --enable-fastcgi"
- fi
-
- if use force-cgi-redirect; then
- myconf="${myconf} --enable-force-cgi-redirect"
- fi
-
- php-sapi_src_compile
-}
-
-src_install() {
- PHP_INSTALLTARGETS="install"
- php-sapi_src_install
-
- # rename binary
- newbin "${S}/sapi/cgi/php" php-cgi
-}
-
-pkg_postinst() {
- php-sapi_pkg_postinst
- einfo "This is a CGI only build."
-}