summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-29 03:10:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-29 03:10:59 +0000
commitfed12e2174929cfa80372dff30f0501793e2269b (patch)
tree997f6573a25e383b7dd21d13c5c3e8c3fbaf889b /dev-php/php
parentversion bump (diff)
downloadhistorical-fed12e2174929cfa80372dff30f0501793e2269b.tar.gz
historical-fed12e2174929cfa80372dff30f0501793e2269b.tar.bz2
historical-fed12e2174929cfa80372dff30f0501793e2269b.zip
version bump
Diffstat (limited to 'dev-php/php')
-rw-r--r--dev-php/php/Manifest4
-rw-r--r--dev-php/php/files/digest-php-4.3.32
-rw-r--r--dev-php/php/php-4.3.3.ebuild50
3 files changed, 54 insertions, 2 deletions
diff --git a/dev-php/php/Manifest b/dev-php/php/Manifest
index 72e5c769ea20..60f28bf925df 100644
--- a/dev-php/php/Manifest
+++ b/dev-php/php/Manifest
@@ -2,10 +2,10 @@ MD5 4050f7ed6eb4c2864abf0eb05b5140a8 php-4.3.2-r3.ebuild 1141
MD5 b5971dfa118d3b7b3a86044960ecc3f5 php-4.3.2.ebuild 2422
MD5 69261b04b41d4699eb0c55b4b4a10f8e php-4.3.2-r2.ebuild 1184
MD5 6118cb273654c1847c504406f57131da php-5.0_beta1.ebuild 1178
-MD5 4a6e3c863b81979863b6d39b7ab93246 ChangeLog 8655
+MD5 d3aad6c4b39c9940aa86d4dc0d8c728e ChangeLog 8768
MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
MD5 434ff51e4e7de5c6ce8bf855717de268 php-4.3.2-r1.ebuild 991
-MD5 ea2484027c9f59e90e55fcf59e6d8a46 php-4.3.3.ebuild 1216
+MD5 c6f16001024e01ebb2145f4495537c26 php-4.3.3.ebuild 1213
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r1 137
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r2 137
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r3 137
diff --git a/dev-php/php/files/digest-php-4.3.3 b/dev-php/php/files/digest-php-4.3.3
new file mode 100644
index 000000000000..1fecdf01d76d
--- /dev/null
+++ b/dev-php/php/files/digest-php-4.3.3
@@ -0,0 +1,2 @@
+MD5 1171d96104e2ff2cff9e19789a4a1536 php-4.3.3.tar.bz2 3711877
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
diff --git a/dev-php/php/php-4.3.3.ebuild b/dev-php/php/php-4.3.3.ebuild
new file mode 100644
index 000000000000..998108829cfe
--- /dev/null
+++ b/dev-php/php/php-4.3.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.3.ebuild,v 1.1 2003/08/29 03:10:57 robbat2 Exp $
+
+PHPSAPI="cli"
+inherit php eutils
+
+IUSE="${IUSE} readline"
+
+DESCRIPTION="PHP Shell Interpreter"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~mips"
+
+DEPEND_EXTRA="readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="${DEPEND} ${DEPEND_EXTRA}"
+RDEPEND="${RDEPEND} ${DEPEND_EXTRA}"
+
+src_compile() {
+ # Readline and Ncurses are CLI PHP only
+ # readline implies ncurses
+ use ncurses || use readline && use_ncurses="--with-" || use_ncurses="--without-"
+ myconf="${myconf} `use_with readline`"
+ myconf="${myconf} ${use_ncurses}-ncurses"
+
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli"
+
+ php_src_compile
+}
+
+
+src_install() {
+ installtargets="${installtargets} install-cli"
+ php_src_install
+
+ # php executable is located in ./sapi/cli/
+ exeinto /usr/bin
+ doexe sapi/cli/php
+}
+
+pkg_postinst() {
+ php_pkg_postinst
+ einfo "This is a CLI only build."
+ einfo "You can not use it on a webserver."
+}
+pkg_preinst() {
+ php_pkg_preinst
+}