summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2007-06-30 17:23:32 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2007-06-30 17:23:32 +0000
commit4d267a127a74cf71de371ef0d8bfd2458a66e8ef (patch)
treeea6fa6892693430154039e9e3388c68fc542dad4 /dev-php5
parentalpha stable (diff)
downloadhistorical-4d267a127a74cf71de371ef0d8bfd2458a66e8ef.tar.gz
historical-4d267a127a74cf71de371ef0d8bfd2458a66e8ef.tar.bz2
historical-4d267a127a74cf71de371ef0d8bfd2458a66e8ef.zip
* bump, bug #180562
Package-Manager: portage-2.1.3_rc6
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-apc/ChangeLog8
-rw-r--r--dev-php5/pecl-apc/files/digest-pecl-apc-3.0.143
-rw-r--r--dev-php5/pecl-apc/pecl-apc-3.0.14.ebuild67
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-php5/pecl-apc/ChangeLog b/dev-php5/pecl-apc/ChangeLog
index 3cecdf7dfef6..3b46d330c126 100644
--- a/dev-php5/pecl-apc/ChangeLog
+++ b/dev-php5/pecl-apc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/pecl-apc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.24 2007/05/12 14:30:48 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/ChangeLog,v 1.25 2007/06/30 17:23:32 voxus Exp $
+
+*pecl-apc-3.0.14 (30 Jun 2007)
+
+ 30 Jun 2007; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +pecl-apc-3.0.14.ebuild:
+ Version bump, closing bug #180562.
12 May 2007; Luca Longinotti <chtekk@gentoo.org>
pecl-apc-3.0.12_p2.ebuild, pecl-apc-3.0.13.ebuild:
diff --git a/dev-php5/pecl-apc/files/digest-pecl-apc-3.0.14 b/dev-php5/pecl-apc/files/digest-pecl-apc-3.0.14
new file mode 100644
index 000000000000..415ca2aa9d49
--- /dev/null
+++ b/dev-php5/pecl-apc/files/digest-pecl-apc-3.0.14
@@ -0,0 +1,3 @@
+MD5 0f452f936239b6107d3e2e5cda4f4bda APC-3.0.14.tgz 108511
+RMD160 59c76ae8ae4aa237d118e0860c42f11e416751d1 APC-3.0.14.tgz 108511
+SHA256 f05195d163983a8f36336e622e6008bfecd4643d7c5613a6e4a8b07ed735e050 APC-3.0.14.tgz 108511
diff --git a/dev-php5/pecl-apc/pecl-apc-3.0.14.ebuild b/dev-php5/pecl-apc/pecl-apc-3.0.14.ebuild
new file mode 100644
index 000000000000..c516aacf4115
--- /dev/null
+++ b/dev-php5/pecl-apc/pecl-apc-3.0.14.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-apc/pecl-apc-3.0.14.ebuild,v 1.1 2007/06/30 17:23:32 voxus Exp $
+
+PHP_EXT_NAME="apc"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1 confutils
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
+LICENSE="PHP"
+SLOT="0"
+IUSE="mmap"
+
+DEPEND="!dev-php5/eaccelerator !dev-php5/xcache"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_sapi_from cgi apache2
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+ dodoc-php CHANGELOG INSTALL LICENSE NOTICE
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.optimization" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp5.XXXXXX"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+ php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
+ php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of PECL-APC was"
+ elog "installed into ${ROOT}usr/share/php5/apc/."
+}