summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-03-17 23:55:14 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-03-17 23:55:14 +0000
commit56015867a46e65a66045a0faa7169341f760cd90 (patch)
tree73110ca91b8298713896165669bd767cbf721662 /dev-php5
parentCleanup. (diff)
downloadhistorical-56015867a46e65a66045a0faa7169341f760cd90.tar.gz
historical-56015867a46e65a66045a0faa7169341f760cd90.tar.bz2
historical-56015867a46e65a66045a0faa7169341f760cd90.zip
Vbump.
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-http/ChangeLog10
-rw-r--r--dev-php5/pecl-http/files/digest-pecl-http-1.3.13
-rw-r--r--dev-php5/pecl-http/files/digest-pecl-http-1.5.23
-rw-r--r--dev-php5/pecl-http/pecl-http-1.5.2.ebuild (renamed from dev-php5/pecl-http/pecl-http-1.3.1.ebuild)27
4 files changed, 30 insertions, 13 deletions
diff --git a/dev-php5/pecl-http/ChangeLog b/dev-php5/pecl-http/ChangeLog
index d490dc812156..fda88bb5a4f0 100644
--- a/dev-php5/pecl-http/ChangeLog
+++ b/dev-php5/pecl-http/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/pecl-http
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.3 2006/10/02 14:43:35 sebastian Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.4 2007/03/17 23:55:14 chtekk Exp $
+
+*pecl-http-1.5.2 (17 Mar 2007)
+
+ 17 Mar 2007; Luca Longinotti <chtekk@gentoo.org> -pecl-http-1.3.1.ebuild,
+ +pecl-http-1.5.2.ebuild:
+ Version bump.
*pecl-http-1.3.1 (02 Oct 2006)
diff --git a/dev-php5/pecl-http/files/digest-pecl-http-1.3.1 b/dev-php5/pecl-http/files/digest-pecl-http-1.3.1
deleted file mode 100644
index 0f69fbabf163..000000000000
--- a/dev-php5/pecl-http/files/digest-pecl-http-1.3.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 5c5810cff0f70ecc91840c967ce4110c pecl_http-1.3.1.tgz 195134
-RMD160 485ad005e1141bc5ffa58979e5c5260ef44e31ff pecl_http-1.3.1.tgz 195134
-SHA256 962e58eed1e4a36d7ff55636638cc75109ac1ce42e60eb29b97f95c986fd4c69 pecl_http-1.3.1.tgz 195134
diff --git a/dev-php5/pecl-http/files/digest-pecl-http-1.5.2 b/dev-php5/pecl-http/files/digest-pecl-http-1.5.2
new file mode 100644
index 000000000000..7978e12a5927
--- /dev/null
+++ b/dev-php5/pecl-http/files/digest-pecl-http-1.5.2
@@ -0,0 +1,3 @@
+MD5 7df4c9f7cb9023cede5c18913c995fd4 pecl_http-1.5.2.tgz 168058
+RMD160 ecbc203eb0f07fe60c1e4d79885d06cfd5090890 pecl_http-1.5.2.tgz 168058
+SHA256 cd5341c19209a9d10aad8d43e9bf70cfa844bbfa128749b09f4c7f723f199513 pecl_http-1.5.2.tgz 168058
diff --git a/dev-php5/pecl-http/pecl-http-1.3.1.ebuild b/dev-php5/pecl-http/pecl-http-1.5.2.ebuild
index 05df2be78f93..15684b8d6ee8 100644
--- a/dev-php5/pecl-http/pecl-http-1.3.1.ebuild
+++ b/dev-php5/pecl-http/pecl-http-1.5.2.ebuild
@@ -1,20 +1,31 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.3.1.ebuild,v 1.1 2006/10/02 14:43:35 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.5.2.ebuild,v 1.1 2007/03/17 23:55:14 chtekk Exp $
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_PECL_PKG="pecl_http"
PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
inherit php-ext-pecl-r1
-IUSE=""
+KEYWORDS="~amd64 ~x86"
+
DESCRIPTION="Extended HTTP Support for PHP."
-SLOT="0"
LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
-DEPEND="${DEPEND} net-misc/curl"
+DEPEND="net-misc/curl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
need_php_by_category
+
+src_compile() {
+ my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression"
+
+ php-ext-pecl-r1_src_compile
+}