summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-06-28 19:16:07 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-06-28 19:16:07 +0000
commit124b37c80c7d80c54e77baf0dcd29e68e4a06181 (patch)
treea6705605dc98e16af66c6d46637ffcbd2cea01e3 /dev-php
parentVersion bumped (diff)
downloadhistorical-124b37c80c7d80c54e77baf0dcd29e68e4a06181.tar.gz
historical-124b37c80c7d80c54e77baf0dcd29e68e4a06181.tar.bz2
historical-124b37c80c7d80c54e77baf0dcd29e68e4a06181.zip
Version bumped
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpgroupware/Manifest6
-rw-r--r--dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.0031
-rw-r--r--dev-php/phpgroupware/phpgroupware-0.9.14.001.ebuild6
-rw-r--r--dev-php/phpgroupware/phpgroupware-0.9.14.003.ebuild49
4 files changed, 56 insertions, 6 deletions
diff --git a/dev-php/phpgroupware/Manifest b/dev-php/phpgroupware/Manifest
index 18fee967a266..a862fcb00c3d 100644
--- a/dev-php/phpgroupware/Manifest
+++ b/dev-php/phpgroupware/Manifest
@@ -1,5 +1,5 @@
-MD5 d5b790fd5956accfc46969800b01ecbe ChangeLog 713
-MD5 2c33e805b76cafd12fffd6d2e690cb08 phpgroupware-0.9.14.001.ebuild 1454
-MD5 c67a6c9e9aff4d53c728da28e52607f6 phpgroupware-0.9.14.003.ebuild 1427
+MD5 6d55781e2ee6c8d600be5cdc68b45326 ChangeLog 888
+MD5 89ef4eb4c15c48d0dbae766dbc592e94 phpgroupware-0.9.14.001.ebuild 1454
+MD5 a35340887125c6ef78bdcea5747bf30a phpgroupware-0.9.14.003.ebuild 1427
MD5 b96f0aaca255c2a2c5039392a1f25833 files/digest-phpgroupware-0.9.14.001 151
MD5 c508961bd9ace9b7fe77bfc9381aecc9 files/digest-phpgroupware-0.9.14.003 77
diff --git a/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.003 b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.003
new file mode 100644
index 000000000000..0c7306a11609
--- /dev/null
+++ b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.003
@@ -0,0 +1 @@
+MD5 0eb87b98c0227def43da33897902db2a phpgroupware-0.9.14.003.tar.bz2 6092623
diff --git a/dev-php/phpgroupware/phpgroupware-0.9.14.001.ebuild b/dev-php/phpgroupware/phpgroupware-0.9.14.001.ebuild
index 40863ad2bf9a..d413b1d5483d 100644
--- a/dev-php/phpgroupware/phpgroupware-0.9.14.001.ebuild
+++ b/dev-php/phpgroupware/phpgroupware-0.9.14.001.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.14.001.ebuild,v 1.5 2003/04/07 20:13:21 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.14.001.ebuild,v 1.6 2003/06/28 19:15:58 mholzer Exp $
S=${WORKDIR}/phpGroupWare-${PV}
HTTPD_ROOT="/home/httpd/htdocs"
@@ -12,12 +12,12 @@ SRC_URI="http://www.phpgroupware.org/downloads_phpgw/phpGroupWare-${PV}.tar.bz2"
HOMEPAGE="http://www.phpgroupware.org"
LICENSE="GPL-2"
-SLOT="="
+SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha"
IUSE=""
DEPEND="virtual/php
- dev-db/mysql"
+ dev-db/mysql"
pkg_setup() {
diff --git a/dev-php/phpgroupware/phpgroupware-0.9.14.003.ebuild b/dev-php/phpgroupware/phpgroupware-0.9.14.003.ebuild
new file mode 100644
index 000000000000..7bca1e17c972
--- /dev/null
+++ b/dev-php/phpgroupware/phpgroupware-0.9.14.003.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.14.003.ebuild,v 1.1 2003/06/28 19:15:58 mholzer Exp $
+
+S=${WORKDIR}/${PN}
+HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+DESCRIPTION="The phpGroupWare intranet/groupware tool and application framework."
+SRC_URI="http://www.phpgroupware.org/downloads_phpgw/${P}.tar.bz2"
+HOMEPAGE="http://www.phpgroupware.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha"
+IUSE=""
+
+DEPEND="virtual/php
+ dev-db/mysql"
+
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/phpgroupware ] ; then
+ ewarn "You need to unmerge your old phpGroupWare version first."
+ ewarn "phpGroupWare will be installed into ${HTTPD_ROOT}/phpgroupware"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install () {
+ dodir ${HTTPD_ROOT}/phpgroupware
+ cd ${WORKDIR}
+ cp -r . ${D}/${HTTPD_ROOT}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} phpgroupware
+ chmod -R 700 phpgroupware/files
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at http://docs.phpgroupware.org/12-docs/html/admin/x62.html#AEN134 "
+ einfo "to complete the install. You need to add MySQL users and configure phpGroupWare"
+}