summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2003-08-04 23:44:13 +0000
committerStuart Herbert <stuart@gentoo.org>2003-08-04 23:44:13 +0000
commite22055ac66f130b0f7fc0792723f9700053578a3 (patch)
tree5e8231c9b447fcea1a58484b0159c6d99681ad43 /dev-php
parentFixes based on feedback from test users (diff)
downloadhistorical-e22055ac66f130b0f7fc0792723f9700053578a3.tar.gz
historical-e22055ac66f130b0f7fc0792723f9700053578a3.tar.bz2
historical-e22055ac66f130b0f7fc0792723f9700053578a3.zip
Fixes based on feedback from test users
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/jpgraph/Manifest4
-rw-r--r--dev-php/jpgraph/jpgraph-1.12.2.ebuild29
2 files changed, 26 insertions, 7 deletions
diff --git a/dev-php/jpgraph/Manifest b/dev-php/jpgraph/Manifest
index c0cc1e46667f..cca496e4ff48 100644
--- a/dev-php/jpgraph/Manifest
+++ b/dev-php/jpgraph/Manifest
@@ -1,3 +1,3 @@
-MD5 325d87d80dd79570507f3d7a33b13ecc jpgraph-1.12.2.ebuild 2561
-MD5 0d5ce14dd4774f3260cf73d1c3d89f38 ChangeLog 678
+MD5 26d2bf3e442e98c20392782482d78f7e jpgraph-1.12.2.ebuild 2398
+MD5 f3e1aaed1c4a3849ac6ec88b7fb5bb0c ChangeLog 678
MD5 4f6fb9ae9a7dd1daf9b37c4b458bf0d3 files/digest-jpgraph-1.12.2 67
diff --git a/dev-php/jpgraph/jpgraph-1.12.2.ebuild b/dev-php/jpgraph/jpgraph-1.12.2.ebuild
index 800a1009536a..f81601672172 100644
--- a/dev-php/jpgraph/jpgraph-1.12.2.ebuild
+++ b/dev-php/jpgraph/jpgraph-1.12.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Released under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/jpgraph-1.12.2.ebuild,v 1.2 2003/08/04 01:21:56 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/jpgraph-1.12.2.ebuild,v 1.3 2003/08/04 23:43:56 stuart Exp $
#
# Based on the ebuild submitted by ??
@@ -44,12 +44,31 @@ pkg_setup ()
src_install ()
{
- sed -i 's|DEFINE("CACHE_FILE_GROUP", "wwwadmin");|DEFINE("CACHE_FILE_GROUP", "${HTTPD_GROUP}";|' src/jpgraph.php
- sed -i 's|/tmp/jpgraph_cache/|${JPGRAPH_CACHE_DIR}/|g' src/jpgraph.php
+ einfo "Patching jpgraph.php"
+
+ # patch 1:
+ # make jpgraph use the correct group for file permissions
- sed -i 's|DEFINE("USE_CACHE",false);|if (!defined("USE_CACHE")) DEFINE("USE_CACHE", false);|' src/jpgraph.php
+ sed -i "s|^DEFINE(\"CACHE_FILE_GROUP\",\"wwwadmin\");|DEFINE(\"CACHE_FILE_GROUP\", \"${HTTPD_GROUP}\";|" src/jpgraph.php
+
+ # patch 2:
+ # make jpgraph use the correct directory for caching
+
+ sed -i "s|/tmp/jpgraph_cache/|${JPGRAPH_CACHE_DIR}/|g;" src/jpgraph.php
+
+ # patch 3:
+ # switch off the directory cache
+
+ sed -i 's|^DEFINE("USE_CACHE",false);|if (!defined("USE_CACHE")) DEFINE("USE_CACHE", false);|' src/jpgraph.php
+
+ # patch 4:
+ # don't read the READ_CACHE if we're not creating any images in the
+ # cache in the first place (doh)
+
+ sed -i 's|DEFINE("READ_CACHE",true);|DEFINE("READ_CACHE", $USE_CACHE);|' src/jpgraph.php
# install php files
+ einfo "Building list of files to install"
php-lib_src_install src `cd src ; find . -type f -print`
# install documentation
@@ -62,5 +81,5 @@ src_install ()
keepdir "${JPGRAPH_CACHE_DIR}"
fowners ${HTTPD_USER}.${HTTPD_GROUP} "${JPGRAPH_CACHE_DIR}"
- fperms 777 "${JPGRAPH_CACHE_DIR}"
+ fperms 700 "${JPGRAPH_CACHE_DIR}"
}