summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-01-16 01:24:31 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-01-16 01:24:31 +0000
commit4632724d95410909e8f5f0f00705a055a706364a (patch)
tree070645a8a0d2c3f6edadb655ddf5e26c025168a1 /dev-python/bicyclerepair
parentAdded bike.el file for [x]emacs users and info for IDLE integration. Bug #38191 (diff)
downloadhistorical-4632724d95410909e8f5f0f00705a055a706364a.tar.gz
historical-4632724d95410909e8f5f0f00705a055a706364a.tar.bz2
historical-4632724d95410909e8f5f0f00705a055a706364a.zip
Added bike.el file for [x]emacs users and info for IDLE integration. Bug #38191
Diffstat (limited to 'dev-python/bicyclerepair')
-rw-r--r--dev-python/bicyclerepair/Manifest4
-rw-r--r--dev-python/bicyclerepair/bicyclerepair-0.7.1-r1.ebuild42
-rw-r--r--dev-python/bicyclerepair/files/digest-bicyclerepair-0.7.1-r11
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/bicyclerepair/Manifest b/dev-python/bicyclerepair/Manifest
index 63a67edce230..b663a8f3498a 100644
--- a/dev-python/bicyclerepair/Manifest
+++ b/dev-python/bicyclerepair/Manifest
@@ -1,6 +1,6 @@
-MD5 7accd6c6e21bf7a9bc1b86e5d73e3cad ChangeLog 713
+MD5 97afc351e15c588500fc3340966d8325 ChangeLog 716
MD5 53c01139acc4099c37c14e2b7ea167a9 bicyclerepair-0.7.1.ebuild 1055
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
-MD5 c929b1b8ca1b23ceb471045c079c65c5 bicyclerepair-0.7.1-r1.ebuild 1229
+MD5 4727803da6a81956dea407d01e8fdc65 bicyclerepair-0.7.1-r1.ebuild 1350
MD5 1929efd859e004d9dfe70dde4e1c8940 files/digest-bicyclerepair-0.7.1 70
MD5 1929efd859e004d9dfe70dde4e1c8940 files/digest-bicyclerepair-0.7.1-r1 70
diff --git a/dev-python/bicyclerepair/bicyclerepair-0.7.1-r1.ebuild b/dev-python/bicyclerepair/bicyclerepair-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..286ecab5b490
--- /dev/null
+++ b/dev-python/bicyclerepair/bicyclerepair-0.7.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bicyclerepair/bicyclerepair-0.7.1-r1.ebuild,v 1.1 2004/01/16 01:24:23 pythonhead Exp $
+
+inherit distutils
+mydoc="NEWS DESIGN"
+
+
+DESCRIPTION="Bicycle Repair Man is the Python Refactoring Browser,"
+HOMEPAGE="http://bicyclerepair.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bicyclerepair/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+DEPEND="virtual/python"
+
+src_install() {
+ distutils_src_install
+ insinto /usr/share/${PN}
+ doins ide-integration/bike.el
+ rm -f ${D}/usr/bin/bikeemacs.bat
+}
+
+pkg_postinst() {
+ # Enable IDLE integration if Python was compiled with tcltk.
+ PYTHON_VER=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+ config_txt=/usr/lib/python${PYTHON_VER}/tools/idle/config.txt
+ if [ -f "${config_txt}" ];
+ then
+ if [ -z "`grep BicycleRepairMan_Idle ${config_txt}`" ]; then
+ einfo "Appending BicycleRepairman to IDLE.."
+ echo "[BicycleRepairMan_Idle]" >> ${config_txt}
+ fi
+ else
+ einfo "BicycleRepairMan won't integrate with IDLE included in Python 2.3*"
+ fi
+ einfo " "
+ einfo "To use bicyclerepair with Xemacs or GNU Emacs you must be in Python"
+ einfo "mode and add /usr/share/bicyclerepair/bike.el to your .emacs or .init.el"
+}
+
diff --git a/dev-python/bicyclerepair/files/digest-bicyclerepair-0.7.1-r1 b/dev-python/bicyclerepair/files/digest-bicyclerepair-0.7.1-r1
new file mode 100644
index 000000000000..703fbf11735b
--- /dev/null
+++ b/dev-python/bicyclerepair/files/digest-bicyclerepair-0.7.1-r1
@@ -0,0 +1 @@
+MD5 90207f4718602fd1be1b38453febfca5 bicyclerepair-0.7.1.tar.gz 87885