summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-09 08:23:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-09 08:23:00 +0000
commit4d9f58da71960e40783a6f9a43d7e642cb9f509c (patch)
tree2bfbb484c54cdd97ae56fd9d4ec014aed50c8537 /dev-python/blinker
parentBump for #404415 (diff)
downloadhistorical-4d9f58da71960e40783a6f9a43d7e642cb9f509c.tar.gz
historical-4d9f58da71960e40783a6f9a43d7e642cb9f509c.tar.bz2
historical-4d9f58da71960e40783a6f9a43d7e642cb9f509c.zip
Bump for #404149
Package-Manager: portage-2.2.0_alpha90/cvs/Linux x86_64
Diffstat (limited to 'dev-python/blinker')
-rw-r--r--dev-python/blinker/ChangeLog9
-rw-r--r--dev-python/blinker/blinker-1.2.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/blinker/ChangeLog b/dev-python/blinker/ChangeLog
index f49a0e9b9ad6..d64727496a71 100644
--- a/dev-python/blinker/ChangeLog
+++ b/dev-python/blinker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/blinker
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/blinker/ChangeLog,v 1.1 2011/02/12 17:31:24 arfrever Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blinker/ChangeLog,v 1.2 2012/03/09 08:23:00 patrick Exp $
+
+*blinker-1.2 (09 Mar 2012)
+
+ 09 Mar 2012; Patrick Lauer <patrick@gentoo.org> +blinker-1.2.ebuild:
+ Bump for #404149
*blinker-1.1 (12 Feb 2011)
diff --git a/dev-python/blinker/blinker-1.2.ebuild b/dev-python/blinker/blinker-1.2.ebuild
new file mode 100644
index 000000000000..d45242d2b23b
--- /dev/null
+++ b/dev-python/blinker/blinker-1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/blinker/blinker-1.2.ebuild,v 1.1 2012/03/09 08:23:00 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Fast, simple object-to-object and broadcast signaling"
+HOMEPAGE="http://discorporate.us/projects/Blinker/ http://pypi.python.org/pypi/blinker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}