summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-29 01:58:07 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-29 01:58:07 +0000
commitd0735249f86af9a361e54afe9cf5fc08a1515a41 (patch)
treefe28b94298cd847822215380aa6e0eb8095cf759 /dev-python/greenlet/greenlet-0.4.0-r2.ebuild
parentDo not permit builds with CONFIG_USER_NS (diff)
downloadhistorical-d0735249f86af9a361e54afe9cf5fc08a1515a41.tar.gz
historical-d0735249f86af9a361e54afe9cf5fc08a1515a41.tar.bz2
historical-d0735249f86af9a361e54afe9cf5fc08a1515a41.zip
Revision bump, add upstream fixes for gcc-4.8 issues.
Package-Manager: portage-2.2.0_alpha177/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'dev-python/greenlet/greenlet-0.4.0-r2.ebuild')
-rw-r--r--dev-python/greenlet/greenlet-0.4.0-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/greenlet/greenlet-0.4.0-r2.ebuild b/dev-python/greenlet/greenlet-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..1a74c034fade
--- /dev/null
+++ b/dev-python/greenlet/greenlet-0.4.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/greenlet/greenlet-0.4.0-r2.ebuild,v 1.1 2013/05/29 01:58:02 radhermit Exp $
+
+EAPI=5
+
+# Note: greenlet is built-in in pypy
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Lightweight in-process concurrent programming"
+HOMEPAGE="http://pypi.python.org/pypi/greenlet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.0-gcc48.patch )
+
+python_compile() {
+ if [[ ${EPYTHON} == python2* ]]; then
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+ append-flags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ "${PYTHON}" run-tests.py -n || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}