summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2007-02-28 13:10:43 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2007-02-28 13:10:43 +0000
commit95c6ba22d1fef7a1069d32bfcc479a6c146b6829 (patch)
tree1c0276d7c94ce610d6ef90e5e1a98a31ddbbfeb2 /dev-python/ipy/ipy-0.53.ebuild
parentbump to new beta version, package masked because it relies on db-4.5 (diff)
downloadhistorical-95c6ba22d1fef7a1069d32bfcc479a6c146b6829.tar.gz
historical-95c6ba22d1fef7a1069d32bfcc479a6c146b6829.tar.bz2
historical-95c6ba22d1fef7a1069d32bfcc479a6c146b6829.zip
Version bump: cleanup, added examples use-flag, removed patch. Dropped 0.42.
Package-Manager: portage-2.1.2-r10
Diffstat (limited to 'dev-python/ipy/ipy-0.53.ebuild')
-rw-r--r--dev-python/ipy/ipy-0.53.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ipy/ipy-0.53.ebuild b/dev-python/ipy/ipy-0.53.ebuild
new file mode 100644
index 000000000000..2b2a7b11264b
--- /dev/null
+++ b/dev-python/ipy/ipy-0.53.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ipy/ipy-0.53.ebuild,v 1.1 2007/02/28 13:10:43 lucass Exp $
+
+inherit eutils distutils
+
+MY_P="${P/ip/IP}"
+
+DESCRIPTION="A python Module for handling IP-Addresses and Networks"
+SRC_URI="http://cheeseshop.python.org/packages/source/I/IPy/${MY_P}.tar.gz"
+HOMEPAGE="http://software.inl.fr/trac/trac.cgi/wiki/IPy"
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ "${python}" test/test_IPy.py || die "src_test failed"
+}
+
+src_install() {
+ DOCS="AUTHORS"
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}
+