summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-01-29 22:40:21 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-01-29 22:40:21 +0000
commitb82600bd7093e7ea566a147eea8892bdca826a0d (patch)
tree1b3622a2b8157d817fd96b66794781aaa16b0bc1 /dev-python/mod_python
parentversion bump (diff)
downloadhistorical-b82600bd7093e7ea566a147eea8892bdca826a0d.tar.gz
historical-b82600bd7093e7ea566a147eea8892bdca826a0d.tar.bz2
historical-b82600bd7093e7ea566a147eea8892bdca826a0d.zip
Fix installation paths, closing bug #39757 and #39758.
Diffstat (limited to 'dev-python/mod_python')
-rw-r--r--dev-python/mod_python/ChangeLog8
-rw-r--r--dev-python/mod_python/Manifest10
-rw-r--r--dev-python/mod_python/files/digest-mod_python-3.0.4-r21
-rw-r--r--dev-python/mod_python/mod_python-3.0.4-r2.ebuild60
4 files changed, 74 insertions, 5 deletions
diff --git a/dev-python/mod_python/ChangeLog b/dev-python/mod_python/ChangeLog
index 2610dd8ad45b..6f48ef8ea153 100644
--- a/dev-python/mod_python/ChangeLog
+++ b/dev-python/mod_python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/mod_python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.13 2004/01/28 13:39:11 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.14 2004/01/29 22:40:09 kloeri Exp $
+
+*mod_python-3.0.4-r2 (29 Jan 2004)
+
+ 29 Jan 2004; Bryan Østergaard,,, <kloeri@gentoo.org>
+ mod_python-3.0.4-r2.ebuild:
+ Fix installation paths, closing bug #39757 and #39758.
*mod_python-3.0.4-r1 (28 Jan 2004)
diff --git a/dev-python/mod_python/Manifest b/dev-python/mod_python/Manifest
index 706b47486944..8dd5ec8b2602 100644
--- a/dev-python/mod_python/Manifest
+++ b/dev-python/mod_python/Manifest
@@ -1,10 +1,12 @@
-MD5 bd31aaab97d2ef379fc67f5122e5e930 ChangeLog 2423
-MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 bd87bc5760aea537ccb33141181edd1b mod_python-3.0.4.ebuild 1743
MD5 e4c76a8d8cfd36c8b102bdf7db583855 mod_python-2.7.10.ebuild 2468
MD5 48ad7614a54310d19160d57e87516d5c mod_python-3.0.4-r1.ebuild 1876
+MD5 670a497a92cc4e4df6e313b70c7235d5 mod_python-3.0.4-r2.ebuild 1875
+MD5 accc23d8850ba77853c977070de24ad3 ChangeLog 2601
+MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 05bbbfafd26dcf70f83fcc2b015751dc files/16_mod_python.conf 1106
-MD5 1fbcf045bdfe9827a893a88a56407656 files/digest-mod_python-3.0.4 65
-MD5 eedde8a8dd90829d24fdb18cc86054f6 files/digest-mod_python-2.7.10 66
MD5 1fbcf045bdfe9827a893a88a56407656 files/digest-mod_python-3.0.4-r1 65
+MD5 1fbcf045bdfe9827a893a88a56407656 files/digest-mod_python-3.0.4-r2 65
MD5 01ce560a5062d990e685e78b756fa5ba files/mod_python.conf 70
+MD5 eedde8a8dd90829d24fdb18cc86054f6 files/digest-mod_python-2.7.10 66
+MD5 1fbcf045bdfe9827a893a88a56407656 files/digest-mod_python-3.0.4 65
diff --git a/dev-python/mod_python/files/digest-mod_python-3.0.4-r2 b/dev-python/mod_python/files/digest-mod_python-3.0.4-r2
new file mode 100644
index 000000000000..3eefc4f3ee99
--- /dev/null
+++ b/dev-python/mod_python/files/digest-mod_python-3.0.4-r2
@@ -0,0 +1 @@
+MD5 d4a51a049f84c5150878625911d8f1d5 mod_python-3.0.4.tgz 218692
diff --git a/dev-python/mod_python/mod_python-3.0.4-r2.ebuild b/dev-python/mod_python/mod_python-3.0.4-r2.ebuild
new file mode 100644
index 000000000000..a455b55e3069
--- /dev/null
+++ b/dev-python/mod_python/mod_python-3.0.4-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.0.4-r2.ebuild,v 1.1 2004/01/29 22:40:09 kloeri Exp $
+
+inherit python
+
+DESCRIPTION="An Apache2 DSO providing an embedded Python interpreter"
+HOMEPAGE="http://www.modpython.org/"
+SRC_URI="http://www.apache.org/dist/httpd/modpython/${P}.tgz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lang/python
+ >=net-www/apache-2.0"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ sed -i -e 's:mod_python.so :mod_python.so $(DESTDIR):' Makefile.in
+ # remove optimisations, we do that outside portage
+ sed -i -e 's:--optimize 2:--prefix=${DESTDIR}/usr --no-compile:' dist/Makefile.in
+
+ # Fix compilation when using Python-2.3
+ has_version ">=dev-lang/python-2.3" && \
+ sed -i -e 's:LONG_LONG:PY_LONG_LONG:g' \
+ "${S}/src/requestobject.c"
+}
+
+src_compile() {
+ ./configure --with-apxs=/usr/sbin/apxs2 || die
+ make OPT="`apxs2 -q CFLAGS` -fPIC" || die
+}
+
+src_install() {
+ dodir /usr/lib/apache2-extramodules
+ make install DESTDIR=${D} LIBEXECDIR=/usr/lib/apache2-extramodules || die
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/16_mod_python.conf
+ dodoc ${FILESDIR}/16_mod_python.conf README NEWS CREDITS COPYRIGHT
+ dohtml doc-html/*
+ insinto /usr/share/doc/${PF}/html/icons
+ doins doc-html/icons/*
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/mod_python
+
+ einfo "To have Apache run python programs, please do the following:"
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PYTHON\""
+ einfo "That will setup Apache to load python when it starts."
+ einfo
+ einfo "If you're new to mod_python there's a manual and tutorial"
+ einfo "installed in /usr/share/doc/${PF}/html/index.html."
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}