summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2005-04-22 16:25:05 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2005-04-22 16:25:05 +0000
commitb17641da718778f27328dec31400772bbe1f6aae (patch)
tree5dae6356baa8c829e7fe8d85541582a9450a2042 /dev-python/nevow
parentfixed ~archs (diff)
downloadhistorical-b17641da718778f27328dec31400772bbe1f6aae.tar.gz
historical-b17641da718778f27328dec31400772bbe1f6aae.tar.bz2
historical-b17641da718778f27328dec31400772bbe1f6aae.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-python/nevow')
-rw-r--r--dev-python/nevow/ChangeLog10
-rw-r--r--dev-python/nevow/Manifest4
-rw-r--r--dev-python/nevow/files/digest-nevow-0.4.11
-rw-r--r--dev-python/nevow/nevow-0.4.1.ebuild34
4 files changed, 46 insertions, 3 deletions
diff --git a/dev-python/nevow/ChangeLog b/dev-python/nevow/ChangeLog
index 1b5eff5478c9..b59dd3638aef 100644
--- a/dev-python/nevow/ChangeLog
+++ b/dev-python/nevow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/nevow
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/ChangeLog,v 1.3 2004/06/25 01:34:51 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/ChangeLog,v 1.4 2005/04/22 16:25:05 lordvan Exp $
+
+*nevow-0.4.1 (22 Apr 2005)
+
+ 22 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> +nevow-0.4.1.ebuild:
+ version bump
+ removed twisted dependency since it can be run without twisted
*nevow-0.2.0 (07 Jun 2004)
diff --git a/dev-python/nevow/Manifest b/dev-python/nevow/Manifest
index ba0b8a0e2988..fe5636f51b22 100644
--- a/dev-python/nevow/Manifest
+++ b/dev-python/nevow/Manifest
@@ -1,6 +1,8 @@
MD5 c27b0dcebd9ee32aae521ce22428c878 nevow-0.2.0.ebuild 995
+MD5 70cde4aa6304a884bafc45de30a1abef nevow-0.4.1.ebuild 912
MD5 8175847cff1da68f68bb009949b375cd nevow-0.1.ebuild 874
-MD5 d6222fbcb95248561bab4ea7dd06745b ChangeLog 462
+MD5 995955fa6f1ccf7138bc21b0ebd1665c ChangeLog 646
MD5 19df39ef54fc4a8677998f19bb6046ac metadata.xml 218
MD5 a8b25c9050527be54829343c1c21910a files/digest-nevow-0.2.0 63
+MD5 2998dda354834e366da7bd2e8fafc8be files/digest-nevow-0.4.1 63
MD5 8a2fdcf3b007798083d424c0a4bf9c67 files/digest-nevow-0.1 61
diff --git a/dev-python/nevow/files/digest-nevow-0.4.1 b/dev-python/nevow/files/digest-nevow-0.4.1
new file mode 100644
index 000000000000..6dd452d05a7d
--- /dev/null
+++ b/dev-python/nevow/files/digest-nevow-0.4.1
@@ -0,0 +1 @@
+MD5 a7402e4571a23b99c59ce4e7d354f7ff nevow-0.4.1.tar.gz 319490
diff --git a/dev-python/nevow/nevow-0.4.1.ebuild b/dev-python/nevow/nevow-0.4.1.ebuild
new file mode 100644
index 000000000000..ddf441b9fbbd
--- /dev/null
+++ b/dev-python/nevow/nevow-0.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/nevow-0.4.1.ebuild,v 1.1 2005/04/22 16:25:05 lordvan Exp $
+
+inherit distutils
+
+# for alphas,..
+MY_PV="${PV/_alpha/alpha}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Nevow is a next-generation web application templating system, based on the ideas developed in the Twisted Woven package."
+HOMEPAGE="http://www.nevow.org/"
+SRC_URI="http://www.nevow.org/releases/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.2"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ dodoc README
+
+ # other docs are in subdirs so i use cp -r instead of insinto
+ cp -r ${S}/doc ${D}/usr/share/doc/${PF}/
+ cp -r ${S}/examples ${D}/usr/share/doc/${PF}/
+
+ # FIXME:
+ # should i install tutorial,pdfs,.. when USE="doc"?
+} \ No newline at end of file