summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-15 21:42:01 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-15 21:42:01 +0000
commitbce8d52b61f7920b140022e51fd2270ea982459e (patch)
treecff5fef864c26c4ac4c0ed4d7e27e827987b84d7 /dev-python/orbit-python
parentdo the logging corretly (diff)
downloadhistorical-bce8d52b61f7920b140022e51fd2270ea982459e.tar.gz
historical-bce8d52b61f7920b140022e51fd2270ea982459e.tar.bz2
historical-bce8d52b61f7920b140022e51fd2270ea982459e.zip
updated to latest version
Diffstat (limited to 'dev-python/orbit-python')
-rw-r--r--dev-python/orbit-python/files/digest-orbit-python-0.3.11
-rw-r--r--dev-python/orbit-python/orbit-python-0.3.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/orbit-python/files/digest-orbit-python-0.3.1 b/dev-python/orbit-python/files/digest-orbit-python-0.3.1
new file mode 100644
index 000000000000..59850edc59e9
--- /dev/null
+++ b/dev-python/orbit-python/files/digest-orbit-python-0.3.1
@@ -0,0 +1 @@
+MD5 104a33e3285ecffd7b437599d3b3612f orbit-python-0.3.1.tar.gz 299008
diff --git a/dev-python/orbit-python/orbit-python-0.3.1.ebuild b/dev-python/orbit-python/orbit-python-0.3.1.ebuild
new file mode 100644
index 000000000000..412148d3d877
--- /dev/null
+++ b/dev-python/orbit-python/orbit-python-0.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/orbit-python/orbit-python-0.3.1.ebuild,v 1.1 2001/11/15 21:42:01 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ORBit bindings for Python"
+SRC_URI="http://orbit-python.sault.org/files/${P}.tar.gz"
+HOMEPAGE="http://orbit-python.sault.org/"
+
+DEPEND=">=dev-libs/glib-1.2.10
+ >=gnome-base/ORBit-0.5.10-r1
+ virtual/python"
+
+src_compile() {
+ CFLAGS="$CFLAGS `gnome-config --cflags libIDL`"
+
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --with-libIDL-prefix=/usr \
+ --with-orbit-prefix=/usr
+ assert
+
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}