summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-07 20:44:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-07 20:44:42 +0000
commit3d8c655754904e593d79fbf5ee60f014d5aadcf9 (patch)
treef3ef002bdec0c56f83e2fd19a46ad83be63929de /dev-python/ply
parentVersion bump. Unicode 5.1 support and fontconfig files. (diff)
downloadhistorical-3d8c655754904e593d79fbf5ee60f014d5aadcf9.tar.gz
historical-3d8c655754904e593d79fbf5ee60f014d5aadcf9.tar.bz2
historical-3d8c655754904e593d79fbf5ee60f014d5aadcf9.zip
Bump
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'dev-python/ply')
-rw-r--r--dev-python/ply/ChangeLog7
-rw-r--r--dev-python/ply/ply-3.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/ply/ChangeLog b/dev-python/ply/ChangeLog
index 0d9c9789dce6..14ab13ff1623 100644
--- a/dev-python/ply/ChangeLog
+++ b/dev-python/ply/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ply
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.11 2009/08/29 23:15:33 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ChangeLog,v 1.12 2009/09/07 20:44:42 patrick Exp $
+
+*ply-3.3 (07 Sep 2009)
+
+ 07 Sep 2009; Patrick Lauer <patrick@gentoo.org> +ply-3.3.ebuild:
+ Bump
*ply-3.2 (29 Aug 2009)
diff --git a/dev-python/ply/ply-3.3.ebuild b/dev-python/ply/ply-3.3.ebuild
new file mode 100644
index 000000000000..fe25207b94fc
--- /dev/null
+++ b/dev-python/ply/ply-3.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ply/ply-3.3.ebuild,v 1.1 2009/09/07 20:44:42 patrick Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python Lex-Yacc library"
+SRC_URI="http://www.dabeaz.com/ply/${P}.tar.gz"
+HOMEPAGE="http://www.dabeaz.com/ply/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="examples"
+
+src_prepare() {
+ sed -e "s/print repr(result)/print(repr(result))/" -i test/testyacc.py || die "sed failed"
+}
+
+src_test() {
+ python_enable_pyc
+
+ cd test
+
+ testing() {
+ "$(PYTHON)" testlex.py || return 1
+ "$(PYTHON)" testyacc.py || return 1
+ }
+ python_execute_function testing
+
+ python_disable_pyc
+}
+
+src_install() {
+ DOCS="ANNOUNCE CHANGES"
+ distutils_src_install
+ dohtml doc/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}