summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-06-25 08:11:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-06-25 08:11:05 +0000
commit437c22f32ee67d1a04406ceedfd577ee33654ca8 (patch)
tree0a8ae89cc53dddc66564f6d934dea511aa02736b /dev-python/psycopg/psycopg-2.5.1.ebuild
parentBump (diff)
downloadhistorical-437c22f32ee67d1a04406ceedfd577ee33654ca8.tar.gz
historical-437c22f32ee67d1a04406ceedfd577ee33654ca8.tar.bz2
historical-437c22f32ee67d1a04406ceedfd577ee33654ca8.zip
Bump
Package-Manager: portage-2.2.0_alpha185/cvs/Linux x86_64
Diffstat (limited to 'dev-python/psycopg/psycopg-2.5.1.ebuild')
-rw-r--r--dev-python/psycopg/psycopg-2.5.1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/psycopg/psycopg-2.5.1.ebuild b/dev-python/psycopg/psycopg-2.5.1.ebuild
new file mode 100644
index 000000000000..b34919907989
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.5.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.5.1.ebuild,v 1.1 2013/06/25 08:10:50 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc examples"
+
+RDEPEND=">=dev-db/postgresql-base-8.1"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile() {
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+
+ [[ ${EPYTHON} != python3* ]] && append-flags -fno-strict-aliasing
+
+ distutils-r1_python_compile
+}
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-2.4.2-setup.py.patch"
+ )
+
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
+ fi
+
+# if use mxdatetime; then
+# sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die
+# fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc -j1 html text
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc doc/{HACKING,SUCCESS}
+
+ if use doc; then
+ dodoc doc/psycopg2.txt
+ dohtml -r doc/html/.
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/.
+ fi
+}