summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2011-11-10 23:23:01 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2011-11-10 23:23:01 +0000
commit6e573aa43d2d8694c6e699d450b4c1cefdc45eb4 (patch)
treec751c71f9e5d9b21bb665a76f87d1bf43c1890c6 /dev-python/pydns/pydns-3.0.1.ebuild
parentImported qt-mobility from qting-edge. (diff)
downloadhistorical-6e573aa43d2d8694c6e699d450b4c1cefdc45eb4.tar.gz
historical-6e573aa43d2d8694c6e699d450b4c1cefdc45eb4.tar.bz2
historical-6e573aa43d2d8694c6e699d450b4c1cefdc45eb4.zip
rev-bump and slotting python2 version, version-bump and slotting python3 version. slot=3 replaces dev-python/py3dns.
Package-Manager: portage-2.2.0_alpha72/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pydns/pydns-3.0.1.ebuild')
-rw-r--r--dev-python/pydns/pydns-3.0.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pydns/pydns-3.0.1.ebuild b/dev-python/pydns/pydns-3.0.1.ebuild
new file mode 100644
index 000000000000..c0346d976f76
--- /dev/null
+++ b/dev-python/pydns/pydns-3.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/pydns-3.0.1.ebuild,v 1.1 2011/11/10 23:23:01 sbriesen Exp $
+
+EAPI="4"
+PYTHON_DEPEND="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.*"
+
+inherit distutils
+
+DESCRIPTION="Python module for DNS (Domain Name Service)"
+HOMEPAGE="http://pydns.sourceforge.net/ http://pypi.python.org/pypi/pydns"
+SRC_URI="http://downloads.sourceforge.net/project/pydns/py3dns/${P/py/py3}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="!dev-python/py3dns
+ virtual/libiconv"
+RDEPEND=""
+
+DOCS="CHANGES CREDITS"
+PYTHON_MODNAME="DNS"
+
+S="${WORKDIR}/${P/py/py3}"
+
+src_prepare() {
+ # Don't compile bytecode.
+ sed -i -e 's:^\(compile\|optimize\).*:\1 = 0:g' setup.cfg
+
+ # cleanup docs
+ rm -f -- "README-guido.txt"
+ mv -f -- "README.txt" "README"
+ mv -f -- "CREDITS.txt" "CREDITS"
+}
+
+src_install(){
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ doins tests/*.py tools/*.py
+ fi
+}