summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-04-20 12:33:03 +0000
committerMarien Zwart <marienz@gentoo.org>2006-04-20 12:33:03 +0000
commite9675d0f87f3f476e3250069b6e2e1df2a92ec6a (patch)
treef089cd036ea2cc69e1395ecf8c4e4a30541bcf61 /dev-python/pylint
parentVersion bump. (diff)
downloadhistorical-e9675d0f87f3f476e3250069b6e2e1df2a92ec6a.tar.gz
historical-e9675d0f87f3f476e3250069b6e2e1df2a92ec6a.tar.bz2
historical-e9675d0f87f3f476e3250069b6e2e1df2a92ec6a.zip
Version bump with more robust cleanup of test files and a friendlier failure if pylint-gui is run without Tkinter present (bug #120771)
Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog9
-rw-r--r--dev-python/pylint/Manifest10
-rw-r--r--dev-python/pylint/files/digest-pylint-0.11.03
-rw-r--r--dev-python/pylint/files/pylint-0.11.0-gui-no-tkinter.patch17
-rw-r--r--dev-python/pylint/pylint-0.11.0.ebuild56
5 files changed, 94 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 232f41030018..39fa80dbc1ab 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pylint
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.27 2006/04/01 15:24:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.28 2006/04/20 12:33:03 marienz Exp $
+
+*pylint-0.11.0 (20 Apr 2006)
+
+ 20 Apr 2006; Marien Zwart <marienz@gentoo.org>
+ +files/pylint-0.11.0-gui-no-tkinter.patch, +pylint-0.11.0.ebuild:
+ Version bump with more robust cleanup of test files and a friendlier failure
+ if pylint-gui is run without Tkinter present (bug #120771)
01 Apr 2006; Aron Griffis <agriffis@gentoo.org> pylint-0.10.0.ebuild:
Mark 0.10.0 ~ia64
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index a436ab7a327e..ecef91d6c7b2 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 92b110d6b915fc46a5ee2cad2385d0c3 ChangeLog 4299
RMD160 e6a3499cf4426b7744f1172983e58a4d37ee14d6 ChangeLog 4299
SHA256 bc4082a11f6238802e822d36fb91ecd426cec2b93fd651293a92ef8780a7a75c ChangeLog 4299
@@ -58,3 +61,10 @@ SHA256 2ddc72504dd0fb5c4c22e211e041bb8fd6af089a287be0496d586399c62ee3a1 pylint-0
MD5 3cc1a48ecff87e0cb9ba6e60865febde pylint-0.9.0.ebuild 1758
RMD160 9d8e61beea92d28ab7e1d96ca454f5bf8f6ea457 pylint-0.9.0.ebuild 1758
SHA256 e9e6ace9d30daa2386c56f6ed1463c564416ae74bbf05f9666b2510f1d237a64 pylint-0.9.0.ebuild 1758
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2.2 (GNU/Linux)
+
+iD8DBQFER3+KW78445TWHXcRAhOEAJ9qXh5pqBtPF0hLYr5ehmXOpQkZdQCfU6Os
+uqJ8Yom5rSRu6otiIdp6Dws=
+=Jk6s
+-----END PGP SIGNATURE-----
diff --git a/dev-python/pylint/files/digest-pylint-0.11.0 b/dev-python/pylint/files/digest-pylint-0.11.0
new file mode 100644
index 000000000000..5ff0b145b4c6
--- /dev/null
+++ b/dev-python/pylint/files/digest-pylint-0.11.0
@@ -0,0 +1,3 @@
+MD5 6c2cd68c49c5a672124c2399b248fb3b pylint-0.11.0.tar.gz 138311
+RMD160 4e25d34a477af791fc2019ff69506f8b319a8351 pylint-0.11.0.tar.gz 138311
+SHA256 5ff2de5008ef5a82a86702ea46bf38f7743aa5a47679bfd908e34be67b96cae7 pylint-0.11.0.tar.gz 138311
diff --git a/dev-python/pylint/files/pylint-0.11.0-gui-no-tkinter.patch b/dev-python/pylint/files/pylint-0.11.0-gui-no-tkinter.patch
new file mode 100644
index 000000000000..ac967247141f
--- /dev/null
+++ b/dev-python/pylint/files/pylint-0.11.0-gui-no-tkinter.patch
@@ -0,0 +1,17 @@
+=== modified file 'a/bin/pylint-gui' (properties changed)
+--- a/bin/pylint-gui
++++ b/bin/pylint-gui
+@@ -1,4 +1,12 @@
+ #!/usr/bin/env python
+ import sys
++
++try:
++ import Tkinter
++except ImportError:
++ print 'Importing Tkinter failed. You probably have to enable the tcltk'
++ print 'USE flag on python.'
++ sys.exit(1)
++
+ from pylint import gui
+ gui.Run(sys.argv[1:])
+
diff --git a/dev-python/pylint/pylint-0.11.0.ebuild b/dev-python/pylint/pylint-0.11.0.ebuild
new file mode 100644
index 000000000000..0d95ad2ddb62
--- /dev/null
+++ b/dev-python/pylint/pylint-0.11.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.11.0.ebuild,v 1.1 2006/04/20 12:33:03 marienz Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="PyLint is a tool to check if a Pyhon module satisfies a coding standard"
+SRC_URI="ftp://ftp.logilab.org/pub/pylint/${P}.tar.gz"
+HOMEPAGE="http://www.logilab.org/projects/pylint/"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~ia64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+DEPEND="|| ( >=dev-python/optik-1.4 >=dev-lang/python-2.3 )
+ >=dev-python/logilab-common-0.13.0
+ >=dev-python/astng-0.16.0"
+
+DOCS="doc/*.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # This test fails
+ mv test/input/func_format.py test/input/func_format.py.skipped
+
+ # Disabling the above test triggers some extra TODOs
+ epatch "${FILESDIR}/${PN}-0.10.0-extra-todo.patch"
+ # Make the test that tries to import gtk a bit less strict
+ epatch "${FILESDIR}/${PN}-0.10.0-extra-gtk-disable.patch"
+
+ # Make pylint-gui print a gentoo-specific message if Tkinter is missing
+ epatch "${FILESDIR}/${P}-gui-no-tkinter.patch"
+}
+
+src_install() {
+ distutils_src_install
+ # do not install the test suite (we ran it from src_test already
+ # and it makes .py[co] generation very noisy because there are
+ # files with SyntaxErrors in there)
+ python_version
+ rm -rf "${D}"/usr/lib*/python${PYVER}/site-packages/pylint/test
+}
+
+src_test() {
+ # The tests will not work properly from the source dir, so do a
+ # temporary install:
+ "${python}" setup.py install --home="${T}/test" || die "test copy failed"
+ # dir needs to be this or the tests fail
+ cd "${T}/test/lib/python/pylint/test"
+ PYTHONPATH="${T}/test/lib/python" "${python}" runtests.py || \
+ die "tests failed"
+ cd "${S}"
+ rm -rf "${T}/test"
+}