summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-01-21 20:55:53 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-01-21 20:55:53 +0000
commit7e6d3a90981a8854a7e7deb8a56901acef830dd5 (patch)
tree52a3c3f737c8b5f26d2063cf6f272a4c0eccba7b /dev-python/pyparted
parentAdded ~ppc. (diff)
downloadhistorical-7e6d3a90981a8854a7e7deb8a56901acef830dd5.tar.gz
historical-7e6d3a90981a8854a7e7deb8a56901acef830dd5.tar.bz2
historical-7e6d3a90981a8854a7e7deb8a56901acef830dd5.zip
Added -fPIC to allow successful compilation on amd64.
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog6
-rw-r--r--dev-python/pyparted/Manifest14
-rw-r--r--dev-python/pyparted/pyparted-1.6.9.ebuild8
3 files changed, 23 insertions, 5 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index 64bf12ceaeaf..05d80597fdc2 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyparted
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.8 2005/01/04 18:28:06 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.9 2005/01/21 20:55:53 cryos Exp $
+
+ 21 Jan 2005; Marcus D. Hanwell <cryos@gentoo.org> pyparted-1.6.9.ebuild:
+ Added append-flags -fPIC as this is needed for compilation on amd64. Applied
+ globally as this package only produces one shared object.
04 Jan 2005; Chris Gianelloni <wolf31o2@gentoo.org> pyparted-1.6.9.ebuild:
Marking stable on x86 and amd64 in preparation for 2005.0's release.
diff --git a/dev-python/pyparted/Manifest b/dev-python/pyparted/Manifest
index 0540f97afc7f..26923517140d 100644
--- a/dev-python/pyparted/Manifest
+++ b/dev-python/pyparted/Manifest
@@ -1,6 +1,16 @@
-MD5 82d3bf78d36e6a26b1226e353a8bb6b9 pyparted-1.6.9.ebuild 876
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 86c4c5432c6c3a6b8e5bcb4de2eac0b7 pyparted-1.6.9.ebuild 1021
MD5 3e969922cc9b62c92a80cd5a108eeb9c pyparted-1.6.6.ebuild 878
-MD5 33434206c34d5a3cb6041329be336356 ChangeLog 1124
+MD5 d5670e6395be6dec66e3f3530060915e ChangeLog 1336
MD5 d86e5b5e47260e5a965eae2afe6d6d40 metadata.xml 159
MD5 1c3b5c95a85ac9c079423549c7922a84 files/digest-pyparted-1.6.6 69
MD5 d0b426a010ec790060151f6c56b4aaa6 files/digest-pyparted-1.6.9 69
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFB8WxdntT9W3vfTuoRAszvAJ9IyWA0Oirw8WjWMxscL6y7frfUpACfXNmn
+UFcpJJs0y3f2uoMJysjV3co=
+=ITvz
+-----END PGP SIGNATURE-----
diff --git a/dev-python/pyparted/pyparted-1.6.9.ebuild b/dev-python/pyparted/pyparted-1.6.9.ebuild
index aaeaceaad4cd..cd9579a8b3fe 100644
--- a/dev-python/pyparted/pyparted-1.6.9.ebuild
+++ b/dev-python/pyparted/pyparted-1.6.9.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.6.9.ebuild,v 1.3 2005/01/04 18:28:06 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.6.9.ebuild,v 1.4 2005/01/21 20:55:53 cryos Exp $
RH_EXTRAVERSION="2"
-inherit eutils rpm
+inherit eutils rpm flag-o-matic
DESCRIPTION="Python bindings for parted"
HOMEPAGE="http://fedora.redhat.com"
@@ -24,6 +24,10 @@ src_unpack() {
src_compile() {
cd ${S}
+ # -fPIC needed for compilation on amd64, applied globally as only one shared
+ # lib is produced by this package.
+ append-flags -fPIC
+
# This is needed otherwise it won't build
# If anyone wants to figure out why... go ahead!
export LDFLAGS="-ldl"