summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-17 09:13:52 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-17 09:13:52 +0000
commit7b62bd28e1c404cfda99a930bd27e131943cd516 (patch)
treee7444bf17d73b71a02772707a4ab4e9967599ce1 /dev-python/sip
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadhistorical-7b62bd28e1c404cfda99a930bd27e131943cd516.tar.gz
historical-7b62bd28e1c404cfda99a930bd27e131943cd516.tar.bz2
historical-7b62bd28e1c404cfda99a930bd27e131943cd516.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/sip-3.3.2.ebuild17
-rw-r--r--dev-python/sip/sip-3.4.ebuild18
2 files changed, 16 insertions, 19 deletions
diff --git a/dev-python/sip/sip-3.3.2.ebuild b/dev-python/sip/sip-3.3.2.ebuild
index 939806c703ab..d172397c225f 100644
--- a/dev-python/sip/sip-3.3.2.ebuild
+++ b/dev-python/sip/sip-3.3.2.ebuild
@@ -1,37 +1,34 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.3.2.ebuild,v 1.3 2002/10/17 16:36:53 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.3.2.ebuild,v 1.4 2002/11/17 09:10:27 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
SRC_URI="http://www.riverbankcomputing.co.uk/download/sip/${P}.tar.gz"
HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+
SLOT="0"
LICENSE="MIT"
KEYWORDS="x86 sparc sparc64 alpha"
+
DEPEND="virtual/glibc
>=dev-lang/python-2.2.1"
src_compile(){
-
- cd ${S}
chmod +x build.py
- mkdir -p ${D}/usr/bin
- mkdir -p ${D}/usr/lib/python2.2/site-packages
+ dodir /usr/bin
+ dodir /usr/lib/python2.2/site-packages
python build.py -l qt-mt -b ${D}/usr/bin -d ${D}/usr/lib/python2.2/site-packages
- make
+ make || die
}
src_install() {
-
cd ${S}/siplib
mv Makefile Makefile.orig
sed s:"cp sip.h /usr/include/python2.2":"cp sip.h /var/tmp/portage/sip-3.3.2/image/usr/include/python2.2": Makefile.orig > Makefile
mv Makefile Makefile.orig2
sed s:"cp sipQt.h /usr/include/python2.2":"cp sipQt.h /var/tmp/portage/sip-3.3.2/image/usr/include/python2.2": Makefile.orig2 > Makefile
cd ${S}
- mkdir -p ${D}/usr/include/python2.2
+ dodir /usr/include/python2.2
make DESTDIR=${D} install || die
dodoc NEWS README THANKS
-
}
diff --git a/dev-python/sip/sip-3.4.ebuild b/dev-python/sip/sip-3.4.ebuild
index 99101bdfee72..fcc51a4a75a1 100644
--- a/dev-python/sip/sip-3.4.ebuild
+++ b/dev-python/sip/sip-3.4.ebuild
@@ -1,32 +1,32 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.4.ebuild,v 1.3 2002/10/17 16:36:53 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.4.ebuild,v 1.4 2002/11/17 09:12:05 vapier Exp $
-S=${WORKDIR}/${PN}-x11-gpl-${PV}
+MY_P="${PN}-x11-gpl-${PV}"
DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
-SRC_URI="http://www.river-bank.demon.co.uk/download/sip/${PN}-x11-gpl-${PV}.tar.gz"
+SRC_URI="http://www.river-bank.demon.co.uk/download/sip/${MY_P}.tar.gz"
HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+
SLOT="0"
LICENSE="MIT"
KEYWORDS="x86 ppc sparc sparc64 alpha"
+
DEPEND="virtual/glibc
>=dev-lang/python-2.2.1"
-src_compile(){
+S=${WORKDIR}/${MY_P}
- cd ${S}
+src_compile(){
chmod +x build.py
mkdir -p ${D}/usr/bin
mkdir -p ${D}/usr/lib/python2.2/site-packages
python build.py -l qt-mt -b ${D}/usr/bin -d ${D}/usr/lib/python2.2/site-packages \
-e ${D}/usr/include/python2.2
- make
+ make || die
}
src_install() {
-
- mkdir -p ${D}/usr/include/python2.2
+ dodir /usr/include/python2.2
make DESTDIR=${D} install || die
dodoc NEWS README THANKS
-
}