summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2012-09-27 18:17:04 +0000
committerMarien Zwart <marienz@gentoo.org>2012-09-27 18:17:04 +0000
commitcbf7e5b262411a1ef259576bdbedbe25dc8ab0b2 (patch)
tree6d7a88dcc5fe8dae03f323f3800a845f75e07044 /dev-python/twisted-names
parentBump to 12.2.0 (bug #423777) with some test-related ebuild improvements. (diff)
downloadhistorical-cbf7e5b262411a1ef259576bdbedbe25dc8ab0b2.tar.gz
historical-cbf7e5b262411a1ef259576bdbedbe25dc8ab0b2.tar.bz2
historical-cbf7e5b262411a1ef259576bdbedbe25dc8ab0b2.zip
Bump to 12.2.0 (bug #423789)
Package-Manager: portage-2.2.0_alpha133/cvs/Linux x86_64
Diffstat (limited to 'dev-python/twisted-names')
-rw-r--r--dev-python/twisted-names/ChangeLog8
-rw-r--r--dev-python/twisted-names/twisted-names-12.2.0.ebuild21
2 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/twisted-names/ChangeLog b/dev-python/twisted-names/ChangeLog
index 71a170f6f7a8..48dad4f9114b 100644
--- a/dev-python/twisted-names/ChangeLog
+++ b/dev-python/twisted-names/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-names
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.66 2012/03/22 07:06:12 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.67 2012/09/27 18:16:45 marienz Exp $
+
+*twisted-names-12.2.0 (27 Sep 2012)
+
+ 27 Sep 2012; Marien Zwart <marienz@gentoo.org> +twisted-names-12.2.0.ebuild:
+ Bump to 12.2.0 (bug #423789)
*twisted-names-12.0.0 (22 Mar 2012)
@@ -263,4 +268,3 @@
08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-names-0.1.0:
initial import
twisted-names was part of the main twisted release
-
diff --git a/dev-python/twisted-names/twisted-names-12.2.0.ebuild b/dev-python/twisted-names/twisted-names-12.2.0.ebuild
new file mode 100644
index 000000000000..bd5dfd898203
--- /dev/null
+++ b/dev-python/twisted-names/twisted-names-12.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-12.2.0.ebuild,v 1.1 2012/09/27 18:16:45 marienz Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="Names"
+
+inherit twisted versionator
+
+DESCRIPTION="A Twisted DNS implementation"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/names twisted/plugins"