summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-08 18:35:34 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-08 18:35:34 +0000
commit37043f6bb0c5189bb0bfcc0ca7b6de824a34b0d5 (patch)
treed9d8f3894ff6a1743fb3e902e8360fa50da1220a /dev-python/vo
parentFix dependencies. Patch by Arfrever. (diff)
downloadhistorical-37043f6bb0c5189bb0bfcc0ca7b6de824a34b0d5.tar.gz
historical-37043f6bb0c5189bb0bfcc0ca7b6de824a34b0d5.tar.bz2
historical-37043f6bb0c5189bb0bfcc0ca7b6de824a34b0d5.zip
Fix dependencies. Avoid breaking strict-aliasing rules. Simplify src_test(). Patch by Arfrever.
Package-Manager: portage-2.2.0_alpha46/cvs/Linux x86_64
Diffstat (limited to 'dev-python/vo')
-rw-r--r--dev-python/vo/ChangeLog6
-rw-r--r--dev-python/vo/vo-0.7.ebuild12
2 files changed, 12 insertions, 6 deletions
diff --git a/dev-python/vo/ChangeLog b/dev-python/vo/ChangeLog
index b875aa756003..25929a0ca58b 100644
--- a/dev-python/vo/ChangeLog
+++ b/dev-python/vo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/vo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/vo/ChangeLog,v 1.7 2011/08/04 18:40:57 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/vo/ChangeLog,v 1.8 2011/08/08 18:35:34 hwoarang Exp $
+
+ 08 Aug 2011; Markos Chandras <hwoarang@gentoo.org> vo-0.7.ebuild:
+ Fix dependencies. Avoid breaking strict-aliasing rules. Simplify src_test().
+ Patch by Arfrever.
04 Aug 2011; SĂ©bastien Fabbro <bicatali@gentoo.org> metadata.xml:
Switched herd to sci-astronomy
diff --git a/dev-python/vo/vo-0.7.ebuild b/dev-python/vo/vo-0.7.ebuild
index f7c5031db72a..8d3359575bd6 100644
--- a/dev-python/vo/vo-0.7.ebuild
+++ b/dev-python/vo/vo-0.7.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/vo/vo-0.7.ebuild,v 1.2 2011/08/04 00:04:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/vo/vo-0.7.ebuild,v 1.3 2011/08/08 18:35:34 hwoarang Exp $
EAPI=3
-PYTHON_DEPEND="*:2.5"
+PYTHON_DEPEND="*:2.6"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4"
+RESTRICT_PYTHON_ABIS="2.4 2.5 *-jython"
inherit distutils eutils
@@ -22,15 +22,17 @@ LICENSE="BSD"
RDEPEND="dev-libs/expat"
DEPEND="${RDEPEND}"
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.6-expat.patch
}
src_test() {
cd test
+
testing() {
- PYTHONPATH="$(ls -d ${S}/build-${PYTHON_ABI}/lib*)" \
- "$(PYTHON)" benchmarks.py || die "test failed with Python ${PYTHON_ABI}"
+ PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" benchmarks.py
}
python_execute_function testing
}