summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 14:10:01 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 14:10:01 +0000
commit5b91e7b0c16904046e94540ec9f544e79e073fb7 (patch)
tree7414bb8e30b64546c5ceebc51f3385d6d373985e /dev-python/webpy
parentBump to 1.1, adding ~amd64 keyword (diff)
downloadhistorical-5b91e7b0c16904046e94540ec9f544e79e073fb7.tar.gz
historical-5b91e7b0c16904046e94540ec9f544e79e073fb7.tar.bz2
historical-5b91e7b0c16904046e94540ec9f544e79e073fb7.zip
Bump to 0.31
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'dev-python/webpy')
-rw-r--r--dev-python/webpy/ChangeLog7
-rw-r--r--dev-python/webpy/webpy-0.31.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/webpy/ChangeLog b/dev-python/webpy/ChangeLog
index 4f93361f14ee..7c0838297355 100644
--- a/dev-python/webpy/ChangeLog
+++ b/dev-python/webpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webpy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.6 2009/01/08 21:29:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.7 2009/02/15 14:10:01 patrick Exp $
+
+*webpy-0.31 (15 Feb 2009)
+
+ 15 Feb 2009; Patrick Lauer <patrick@gentoo.org> +webpy-0.31.ebuild:
+ Bump to 0.31
08 Jan 2009; Patrick Lauer <patrick@gentoo.org> -webpy-0.2.ebuild,
-webpy-0.22.ebuild, -webpy-0.23.ebuild:
diff --git a/dev-python/webpy/webpy-0.31.ebuild b/dev-python/webpy/webpy-0.31.ebuild
new file mode 100644
index 000000000000..932e3ced94fd
--- /dev/null
+++ b/dev-python/webpy/webpy-0.31.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/webpy-0.31.ebuild,v 1.1 2009/02/15 14:10:01 patrick Exp $
+
+inherit distutils
+
+MY_PN="web.py"
+
+DESCRIPTION="A small and simple web framework for python"
+HOMEPAGE="http://www.webpy.org"
+SRC_URI="http://www.webpy.org/static/${MY_PN}-0.3.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/webpy"
+PYTHON_MODNAME="web"
+
+src_test() {
+ TESTS="db template net http utils"
+
+ cd "${S}"
+
+ for TEST in ${TESTS}
+ do
+ ${python} web/${TEST}.py || die "Doctest in web/${TEST}.py failed!"
+ done
+}