summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2012-04-27 12:52:42 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2012-04-27 12:52:42 +0000
commit70d63999d466557fad44e3f230b5d338e5862a80 (patch)
tree780c8e8245bffabeea195bbc7b8b6d9c03544657 /dev-python
parentRemove old version. (diff)
downloadhistorical-70d63999d466557fad44e3f230b5d338e5862a80.tar.gz
historical-70d63999d466557fad44e3f230b5d338e5862a80.tar.bz2
historical-70d63999d466557fad44e3f230b5d338e5862a80.zip
Initial commit, ebuild by idella4
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/errorhandler/ChangeLog11
-rw-r--r--dev-python/errorhandler/Manifest4
-rw-r--r--dev-python/errorhandler/errorhandler-1.1.1.ebuild55
-rw-r--r--dev-python/errorhandler/files/errorhandler-1.1.1-test.patch9
-rw-r--r--dev-python/errorhandler/metadata.xml14
-rw-r--r--dev-python/pkginfo/ChangeLog10
-rw-r--r--dev-python/pkginfo/Manifest3
-rw-r--r--dev-python/pkginfo/metadata.xml14
-rw-r--r--dev-python/pkginfo/pkginfo-0.8.ebuild61
9 files changed, 181 insertions, 0 deletions
diff --git a/dev-python/errorhandler/ChangeLog b/dev-python/errorhandler/ChangeLog
new file mode 100644
index 000000000000..e7c0b2eacc94
--- /dev/null
+++ b/dev-python/errorhandler/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/errorhandler
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/errorhandler/ChangeLog,v 1.1 2012/04/27 12:52:42 tampakrap Exp $
+
+*errorhandler-1.1.1 (27 Apr 2012)
+
+ 27 Apr 2012; Theo Chatzimichos <tampakrap@gentoo.org>
+ +errorhandler-1.1.1.ebuild, +files/errorhandler-1.1.1-test.patch,
+ +metadata.xml:
+ Initial commit, ebuild by idella4
+
diff --git a/dev-python/errorhandler/Manifest b/dev-python/errorhandler/Manifest
new file mode 100644
index 000000000000..b972744a9264
--- /dev/null
+++ b/dev-python/errorhandler/Manifest
@@ -0,0 +1,4 @@
+AUX errorhandler-1.1.1-test.patch 386 RMD160 02d6f86b40b1c525ba8bde7e553231154d8ed00e SHA1 c52e7501e917589a12287472f2b3ff79b6e61b6a SHA256 0f329ac201d3ddf363eb60f388b5c076db5d252dec29fc24b5b3a406385a5eb2
+DIST errorhandler-1.1.1.tar.gz 8321 RMD160 3a60f826eb1bae0e249fdefd3d6c4eb3c598832f SHA1 da35daadd394e9c827e51e190de9a442d8de3d38 SHA256 2baa97a8a256fe72960d196bbdee4404162186f539c4d73b3f1c072db18463e9
+EBUILD errorhandler-1.1.1.ebuild 1155 RMD160 cf842982d7e344f585743c4925147ab073c601ce SHA1 370c004c5d16fc0bc61a2a7a848a01a341b387d2 SHA256 0ae451b1430e465bbbb807428cd840588afb0d5ca63c3166591500aab821e3f0
+MISC metadata.xml 354 RMD160 091888911fc3977462b1015a07a860a68ab6ee9e SHA1 dfd9a92e0cdac92fbeccaae8038db941a4273b09 SHA256 286b386bcfeeacbeace854ed0f9904d845b8397b957963d95bae64534a6decb2
diff --git a/dev-python/errorhandler/errorhandler-1.1.1.ebuild b/dev-python/errorhandler/errorhandler-1.1.1.ebuild
new file mode 100644
index 000000000000..9decdf97eb46
--- /dev/null
+++ b/dev-python/errorhandler/errorhandler-1.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/errorhandler/errorhandler-1.1.1.ebuild,v 1.1 2012/04/27 12:52:42 tampakrap Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="A logging framework handler that tracks when messages above a certain level have been logged"
+HOMEPAGE="http://pypi.python.org/pypi/errorhandler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND} dev-python/pkginfo
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+src_prepare() {
+ sed -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' -i docs/Makefile || die
+ epatch "${FILESDIR}"/${P}-test.patch
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ emake -C docs html
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib/" "$(PYTHON)" -c \
+ "import errorhandler.tests as et, unittest; \
+ unittest.TextTestRunner().run(et.test_suite())"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ if use doc; then
+ dohtml -r docs/_build/html/
+ fi
+ distutils_src_install
+}
diff --git a/dev-python/errorhandler/files/errorhandler-1.1.1-test.patch b/dev-python/errorhandler/files/errorhandler-1.1.1-test.patch
new file mode 100644
index 000000000000..126b508b9923
--- /dev/null
+++ b/dev-python/errorhandler/files/errorhandler-1.1.1-test.patch
@@ -0,0 +1,9 @@
+diff -ur errorhandler-1.1.1.orig/errorhandler/tests.py errorhandler-1.1.1/errorhandler/tests.py
+--- errorhandler/tests.py 2010-03-01 16:41:46.000000000 +0800
++++ errorhandler/tests.py 2012-04-26 02:28:11.991954681 +0800
+@@ -134,3 +134,5 @@
+ tearDown=tearDown,
+ optionflags=options),
+ ))
++if __name__ == "__main__":
++ unittest.main()
diff --git a/dev-python/errorhandler/metadata.xml b/dev-python/errorhandler/metadata.xml
new file mode 100644
index 000000000000..472ba4684030
--- /dev/null
+++ b/dev-python/errorhandler/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johneed@hotmail.com</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <maintainer>
+ <email>tampakrap@gentoo.org</email>
+ <name>Theo Chatzimichos</name>
+ </maintainer>
+ <herd>python</herd>
+</pkgmetadata>
+
diff --git a/dev-python/pkginfo/ChangeLog b/dev-python/pkginfo/ChangeLog
new file mode 100644
index 000000000000..427585fcee9d
--- /dev/null
+++ b/dev-python/pkginfo/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pkginfo
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pkginfo/ChangeLog,v 1.1 2012/04/27 12:49:29 tampakrap Exp $
+
+*pkginfo-0.8 (27 Apr 2012)
+
+ 27 Apr 2012; Theo Chatzimichos <tampakrap@gentoo.org> +metadata.xml,
+ +pkginfo-0.8.ebuild:
+ Initial commit, ebuild by idella4
+
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
new file mode 100644
index 000000000000..e2b3eddefd34
--- /dev/null
+++ b/dev-python/pkginfo/Manifest
@@ -0,0 +1,3 @@
+DIST pkginfo-0.8.tar.gz 22374 RMD160 ba986fa440be81477c446442d6c6b2ce480cfabe SHA1 05e7b8a266c26c2744695a33c6164243e2f7ec92 SHA256 5d37007c0ca72e41367bd2c1a9af6d5927996f516b6df7584110ef7cafd0efbb
+EBUILD pkginfo-0.8.ebuild 1296 RMD160 c6b7f3cd4553e2c55c367b96b180f09ca29a321d SHA1 ff2bddff96055d06e2b754d55a5ec2e7723b4060 SHA256 183016610adefe03a2c4f4533ef19456fc68daf3586c0a05d91ea0e1306816f1
+MISC metadata.xml 354 RMD160 091888911fc3977462b1015a07a860a68ab6ee9e SHA1 dfd9a92e0cdac92fbeccaae8038db941a4273b09 SHA256 286b386bcfeeacbeace854ed0f9904d845b8397b957963d95bae64534a6decb2
diff --git a/dev-python/pkginfo/metadata.xml b/dev-python/pkginfo/metadata.xml
new file mode 100644
index 000000000000..472ba4684030
--- /dev/null
+++ b/dev-python/pkginfo/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>johneed@hotmail.com</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <maintainer>
+ <email>tampakrap@gentoo.org</email>
+ <name>Theo Chatzimichos</name>
+ </maintainer>
+ <herd>python</herd>
+</pkgmetadata>
+
diff --git a/dev-python/pkginfo/pkginfo-0.8.ebuild b/dev-python/pkginfo/pkginfo-0.8.ebuild
new file mode 100644
index 000000000000..49278a55e028
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-0.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pkginfo/pkginfo-0.8.ebuild,v 1.1 2012/04/27 12:49:29 tampakrap Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+inherit distutils eutils
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="http://pypi.python.org/pypi/pkginfo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+LICENSE="MIT"
+SLOT="0"
+DEPEND="doc? ( dev-python/sphinx )
+ dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e 's:SPHINXBUILD = sphinx-build:SPHINXBUILD = /usr/bin/sphinx-build:' \
+ -i docs/Makefile || die
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C docs html
+ fi
+}
+
+src_test() {
+ testing() {
+ pushd pkginfo/tests/ > /dev/null
+ for test in test_*.py; do
+ PYTHONPATH="../../build-${PYTHON_ABI}/lib/" \
+ "$(PYTHON)" "${test}" || die "${test} failed with Python ${PYTHON_ABI}"
+ if [[ $? ]]; then
+ einfo "Test "${test}" successful"
+ fi
+ done
+ popd > /dev/null
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/.build/html/*
+ fi
+
+ if use examples; then
+ insinto usr/share/doc/${PF}/
+ doins -r docs/examples/
+ fi
+}