summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-05-10 16:28:49 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-05-10 16:28:49 +0000
commite1c7e5cbef387d227d1b9fc9bb83e305c432b306 (patch)
treecb507a5870be529422ae4b669fca6a7147e2355c /dev-python
parentUpdated ChaneLog to reflect xfs support stance in pfeifer/gentoo-sources. (diff)
downloadhistorical-e1c7e5cbef387d227d1b9fc9bb83e305c432b306.tar.gz
historical-e1c7e5cbef387d227d1b9fc9bb83e305c432b306.tar.bz2
historical-e1c7e5cbef387d227d1b9fc9bb83e305c432b306.zip
new package
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pythong/ChangeLog9
-rw-r--r--dev-python/pythong/Manifest3
-rw-r--r--dev-python/pythong/files/digest-pythong-2.0.21.02
-rw-r--r--dev-python/pythong/pythong-2.0.21.0.ebuild62
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pythong/ChangeLog b/dev-python/pythong/ChangeLog
new file mode 100644
index 000000000000..360e61f5c286
--- /dev/null
+++ b/dev-python/pythong/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/pythong
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/ChangeLog,v 1.1 2003/05/10 16:28:39 liquidx Exp $
+
+*pythong-2.0.21.0 (10 May 2003)
+
+ 10 May 2003; Alastair Tse <liquidx@gentoo.org> pythong-2.0.21.0.ebuild:
+ initial ebuild. thanks to Federico Moro <zayer@frikis.org>. Bug #20113.
+
diff --git a/dev-python/pythong/Manifest b/dev-python/pythong/Manifest
new file mode 100644
index 000000000000..f0f5910f2085
--- /dev/null
+++ b/dev-python/pythong/Manifest
@@ -0,0 +1,3 @@
+MD5 6e8cc8f015b1c4966caedf261e298e10 pythong-2.0.21.0.ebuild 1507
+MD5 5756b695e04af9a536456b9d96ced5d7 ChangeLog 401
+MD5 ef6104b1ca6dd2b5346eccd49c837859 files/digest-pythong-2.0.21.0 119
diff --git a/dev-python/pythong/files/digest-pythong-2.0.21.0 b/dev-python/pythong/files/digest-pythong-2.0.21.0
new file mode 100644
index 000000000000..06985d9f59b5
--- /dev/null
+++ b/dev-python/pythong/files/digest-pythong-2.0.21.0
@@ -0,0 +1,2 @@
+MD5 ada75f2f39526786f690437d78605996 pythonG-2_0u_2.tgz 195329
+MD5 ad1692872a47162aac9f75efe7e2b1a6 python.pdf 2547987
diff --git a/dev-python/pythong/pythong-2.0.21.0.ebuild b/dev-python/pythong/pythong-2.0.21.0.ebuild
new file mode 100644
index 000000000000..463e33504f1f
--- /dev/null
+++ b/dev-python/pythong/pythong-2.0.21.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/pythong-2.0.21.0.ebuild,v 1.1 2003/05/10 16:28:39 liquidx Exp $
+
+inherit distutils
+
+MY_PN="pythonG"
+# 3rd version number = u = 21st alphabet in english
+# this package has a weird versioning scheme.
+MY_PV="2_0u_2"
+
+IUSE="doc"
+DESCRIPTION="Nice and powerful spanish development enviroment for Python"
+SRC_URI="http://www.colicsoft.com/pub/${MY_PN}-${MY_PV}.tgz
+ doc? ( http://marmota.act.uji.es/MTP/pdf/python.pdf )"
+HOMEPAGE="http://www3.uji.es/~dllorens/PythonG/principal.html"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+S=${WORKDIR}/${MY_PN}-${MY_PV}
+
+RDEPEND=">=dev-lang/python-2.2.2
+ >=dev-lang/tk-8.3.4
+ >=dev-python/pmw-1.1"
+
+pkg_setup() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ eerror "You need to recompile python with Tkinter support."
+ eerror "That means: USE='tcltk' emerge python"
+ echo
+ die "missing tkinter support with installed python"
+ fi
+}
+
+src_compile() {
+ echo -n
+}
+
+src_install() {
+
+ distutils_python_version
+
+ insinto /usr/lib/python${PYVER}/site-packages/
+ doins modulepythong.py
+ doins libpythong/fromidle.py
+
+ exeinto /usr/bin
+ doexe pythong.py
+
+ dodoc leeme.txt
+ cp -r ${S}/{LICENCIA,MANUAL,demos} ${D}/usr/share/doc/${PF}
+ rm -f ${D}/usr/share/doc/${PF}/demos/modulepythong.py
+
+ if [ -n "`use doc`" ]; then
+ insinto /usr/share/doc/${PF}
+ doins ${DISTDIR}/python.pdf
+ fi
+
+}