summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-30 00:42:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-30 00:42:13 +0000
commitef1b41d66ab5e7ccde4d7d4cedd53794ff0e1676 (patch)
tree5bd7ce7f7c995f972a34a1d0afb20de613bb6aa3 /dev-python
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadhistorical-ef1b41d66ab5e7ccde4d7d4cedd53794ff0e1676.tar.gz
historical-ef1b41d66ab5e7ccde4d7d4cedd53794ff0e1676.tar.bz2
historical-ef1b41d66ab5e7ccde4d7d4cedd53794ff0e1676.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-14170-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/uuid/ChangeLog6
-rw-r--r--dev-python/uuid/Manifest4
-rw-r--r--dev-python/uuid/uuid-1.30.ebuild17
3 files changed, 22 insertions, 5 deletions
diff --git a/dev-python/uuid/ChangeLog b/dev-python/uuid/ChangeLog
index a8ba471bf73c..5cdbc6b40af5 100644
--- a/dev-python/uuid/ChangeLog
+++ b/dev-python/uuid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/uuid
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/uuid/ChangeLog,v 1.1 2009/04/19 12:28:43 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/uuid/ChangeLog,v 1.2 2009/08/30 00:42:13 arfrever Exp $
+
+ 30 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ uuid-1.30.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*uuid-1.30 (19 Apr 2009)
diff --git a/dev-python/uuid/Manifest b/dev-python/uuid/Manifest
index 67d11cc24060..5e7548545714 100644
--- a/dev-python/uuid/Manifest
+++ b/dev-python/uuid/Manifest
@@ -1,4 +1,4 @@
DIST uuid-1.30.tar.gz 5811 RMD160 02f7f2c21cb7a18e426e8e4b573d0521baee97f9 SHA1 77ffab33e5052153504a5990dabf7a8505a464bf SHA256 1f87cc004ac5120466f36c5beae48b4c48cc411968eed0eaecd3da82aa96193f
-EBUILD uuid-1.30.ebuild 567 RMD160 6330b6c9634c4008a0c63dbaebba756fad88cba9 SHA1 db1dc1362f3f818d3d84c070f871280c2361a238 SHA256 4b22914aa647977a6fb80693024244ace3c95d0a215e633567aeff0d44c57830
-MISC ChangeLog 328 RMD160 a0a0f58161dcc66476d1c9a8d2d3125bdba3fb02 SHA1 a7335e130edc7bcf01ed7a3a0107706e6c9e4923 SHA256 04469246f9be781112be7637279237e4f68ecaddaf4b7d0d653a8b9b83e796a4
+EBUILD uuid-1.30.ebuild 711 RMD160 9f162508fdced3b54203e6907cb9932eee107259 SHA1 beabf49ade4e9042c53460dd1c9552cc689f9156 SHA256 65507e6b40e4311d5837a53ae34e95b0cb29b385e758c37e0ca1543cd73bad5c
+MISC ChangeLog 452 RMD160 c6b103b2c5815e1d8a30711113c2720b51c20acf SHA1 31eff181567eeb30ba945630ddcc1f31e66c5d20 SHA256 83cf80adfe2e2500f6972b9a7439b1eeca177b5059b27c3d61420f810646c376
MISC metadata.xml 224 RMD160 bb2009757c340fc870e2e7fe5eee501303c70a62 SHA1 e89e8d75b54d9f07a8e7efc9b468a9b74b2d5eec SHA256 79754f25228240ec611264268d0e8dd94cdd8f6cd0473c430343741a2d293824
diff --git a/dev-python/uuid/uuid-1.30.ebuild b/dev-python/uuid/uuid-1.30.ebuild
index 1f48910bb100..a3c98c827ab9 100644
--- a/dev-python/uuid/uuid-1.30.ebuild
+++ b/dev-python/uuid/uuid-1.30.ebuild
@@ -1,13 +1,16 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/uuid/uuid-1.30.ebuild,v 1.3 2009/04/20 11:25:13 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/uuid/uuid-1.30.ebuild,v 1.4 2009/08/30 00:42:13 arfrever Exp $
+
+EAPI="2"
NEED_PYTHON="2.3"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
DESCRIPTION="UUID object and generation functions"
-HOMEPAGE="http://pypi.python.org/pypi/${PN}/${PV}"
+HOMEPAGE="http://pypi.python.org/pypi/uuid"
SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -18,3 +21,13 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
dev-python/setuptools"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+pkg_postinst() {
+ python_mod_optimize uuid.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}