summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-17 08:43:40 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-17 08:43:40 +0000
commit1d5a9e8c301a71d6d314ef4acb78f2c9fdf2f79c (patch)
tree6fa344426ae03a023c38b838aaffd760aa32ceb9 /dev-ruby/actionpack
parentVersion Bump (diff)
downloadhistorical-1d5a9e8c301a71d6d314ef4acb78f2c9fdf2f79c.tar.gz
historical-1d5a9e8c301a71d6d314ef4acb78f2c9fdf2f79c.tar.bz2
historical-1d5a9e8c301a71d6d314ef4acb78f2c9fdf2f79c.zip
Version bump.
Package-Manager: portage-2.1.10.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-2.3.14.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index f9d2df987f7d..2f828edb2d5f 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.186 2011/08/07 18:33:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.187 2011/08/17 08:41:21 graaff Exp $
+
+*actionpack-2.3.14 (17 Aug 2011)
+
+ 17 Aug 2011; Hans de Graaff <graaff@gentoo.org> +actionpack-2.3.14.ebuild:
+ Version bump.
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> actionpack-3.0.9.ebuild:
Add ~ia64/~sparc wrt #351835
diff --git a/dev-ruby/actionpack/actionpack-2.3.14.ebuild b/dev-ruby/actionpack/actionpack-2.3.14.ebuild
new file mode 100644
index 000000000000..7f2e722286bd
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-2.3.14.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-2.3.14.ebuild,v 1.1 2011/08/17 08:41:21 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${PN}-2.3.11-rails3.patch" "${PN}-2.3.10-i18n-0.4.2.patch" )
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-1.1.0:0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.7
+ dev-ruby/activerecord:${SLOT}
+ ~dev-ruby/actionmailer-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+
+ # This tries to load a “vendorized” copy of activerecord that we
+ # will never have. It can now also use a normally installed
+ # version but these tests fail.
+ sed -i -e '/PATH_TO_AR/s:^:#:' -e 's/self.able_to_connect = true/self.able_to_connect = false/' test/active_record_unit.rb || die
+
+ # Fix the testsuite, the symlink is not present in the gem for
+ # some reason
+ ln -s ../../symlink_parent test/fixtures/layout_tests/layouts/symlinked
+
+ # MemCacheStore tests no longer fail gracefully, and it's unlikely for
+ # someone to have them running anyway, so remove them for now.
+ rm test/controller/session/mem_cache_store_test.rb || die
+
+ # Fix tests when run against i18n 0.4.2 which ignores locale
+ # definitions with an empty data section.
+ sed -i -e 's/, {}/, {:test => "test"}/' test/template/render_test.rb || die
+}