summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-17 08:43:40 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-17 08:43:40 +0000
commit1d5a9e8c301a71d6d314ef4acb78f2c9fdf2f79c (patch)
tree6fa344426ae03a023c38b838aaffd760aa32ceb9 /dev-ruby/activerecord
parentVersion Bump (diff)
downloadhistorical-1d5a9e8c301a71d6d314ef4acb78f2c9fdf2f79c.tar.gz
historical-1d5a9e8c301a71d6d314ef4acb78f2c9fdf2f79c.tar.bz2
historical-1d5a9e8c301a71d6d314ef4acb78f2c9fdf2f79c.zip
Version bump.
Package-Manager: portage-2.1.10.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.14.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index ba370a27847e..215fe83cea35 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.164 2011/08/07 18:28:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.165 2011/08/17 08:43:40 graaff Exp $
+
+*activerecord-2.3.14 (17 Aug 2011)
+
+ 17 Aug 2011; Hans de Graaff <graaff@gentoo.org> +activerecord-2.3.14.ebuild:
+ Version bump.
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> activerecord-3.0.9.ebuild:
Add ~ia64/~sparc wrt #351835
diff --git a/dev-ruby/activerecord/activerecord-2.3.14.ebuild b/dev-ruby/activerecord/activerecord-2.3.14.ebuild
new file mode 100644
index 000000000000..0c80c2874fd1
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.14.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.14.ebuild,v 1.1 2011/08/17 08:43:40 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3" #sqlite
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+
+#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
+USE_RUBY=ruby18 \
+ ruby_add_rdepend "
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.10-rails3.patch"
+
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}