summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-30 19:49:29 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-30 19:49:29 +0000
commit9abe8307dec407c716e17f055b62f015ef772cfe (patch)
tree3433060da79c20100e46449f901b7e33070f4082 /dev-ruby/activerecord
parentUpdate LICENSE, see README.licensing in the tarball. Bug 175260. (diff)
downloadhistorical-9abe8307dec407c716e17f055b62f015ef772cfe.tar.gz
historical-9abe8307dec407c716e17f055b62f015ef772cfe.tar.bz2
historical-9abe8307dec407c716e17f055b62f015ef772cfe.zip
Version bump. Add ruby19. Drop arches due to bug 396547.
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-3.1.3.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index d04144f50ac3..d12f61be34ba 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.175 2011/12/27 07:42:55 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.176 2011/12/30 19:46:56 graaff Exp $
+
+*activerecord-3.1.3 (30 Dec 2011)
+
+ 30 Dec 2011; Hans de Graaff <graaff@gentoo.org> +activerecord-3.1.3.ebuild:
+ Version bump. Add ruby19. Drop arches due to bug 396547.
27 Dec 2011; Hans de Graaff <graaff@gentoo.org> activerecord-2.3.14.ebuild:
Also require rdoc for tests. Fixes bug 379551.
diff --git a/dev-ruby/activerecord/activerecord-3.1.3.ebuild b/dev-ruby/activerecord/activerecord-3.1.3.ebuild
new file mode 100644
index 000000000000..a51dbf6bcfa5
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.1.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.1.3.ebuild,v 1.1 2011/12/30 19:46:56 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64"
+IUSE="mysql postgres sqlite3"
+
+RUBY_S="rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.2.1:2.1
+ >=dev-ruby/tzinfo-0.3.29
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.4 )
+ mysql? ( >=dev-ruby/mysql2-0.3.6:0.3 )
+ postgres? ( >=dev-ruby/pg-0.11.0 )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.3
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\)/d' ../Gemfile || die
+ sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ # Avoid tests depending on hash ordering
+ sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}