summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-04-10 10:31:27 +0000
committerMamoru Komachi <usata@gentoo.org>2004-04-10 10:31:27 +0000
commit7f491ea3c9da86b4a4a2d646b27c6d3322fce27b (patch)
tree459417c054f21529cfa2882dd530d75909cae8a5 /dev-ruby/fxruby/fxruby-1.0.28-r1.ebuild
parentAdded to ~ppc (diff)
downloadhistorical-7f491ea3c9da86b4a4a2d646b27c6d3322fce27b.tar.gz
historical-7f491ea3c9da86b4a4a2d646b27c6d3322fce27b.tar.bz2
historical-7f491ea3c9da86b4a4a2d646b27c6d3322fce27b.zip
Use ruby.eclass. virtual/ruby fix
Diffstat (limited to 'dev-ruby/fxruby/fxruby-1.0.28-r1.ebuild')
-rw-r--r--dev-ruby/fxruby/fxruby-1.0.28-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/fxruby/fxruby-1.0.28-r1.ebuild b/dev-ruby/fxruby/fxruby-1.0.28-r1.ebuild
new file mode 100644
index 000000000000..26df101cd01e
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.0.28-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.0.28-r1.ebuild,v 1.1 2004/04/10 10:31:27 usata Exp $
+
+inherit ruby
+
+MY_P=FXRuby-${PV}
+DESCRIPTION="Ruby language binding to the FOX GUI toolkit"
+HOMEPAGE="http://www.fxruby.org/"
+SRC_URI="mirror://sourceforge/fxruby/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-alpha -hppa ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/ruby
+ >=x11-libs/fox-1.0
+ x11-libs/fxscintilla"
+USE_RUBY="ruby16 ruby18 ruby19"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ ruby install.rb config --prefix=/usr || die
+ ruby install.rb setup || die
+}
+
+src_install() {
+ ruby install.rb config --prefix=${D}/usr || die
+ ruby install.rb install || die
+
+ dodoc ANNOUNCE ChangeLog README*
+ cp -dr examples ${D}/usr/share/doc/${PF}
+ dohtml -r doc/*
+}