summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-05-21 15:55:06 +0000
committerTom William Payne <twp@gentoo.org>2003-05-21 15:55:06 +0000
commit6996ac4ed3582a76943ea74adf62acd133971876 (patch)
tree24538ba5ac9f46e2607368f2ed4f4b75776d0de1 /dev-ruby/narray/narray-0.5.7-r1.ebuild
parentInstall docs, marked stable (diff)
downloadhistorical-6996ac4ed3582a76943ea74adf62acd133971876.tar.gz
historical-6996ac4ed3582a76943ea74adf62acd133971876.tar.bz2
historical-6996ac4ed3582a76943ea74adf62acd133971876.zip
Install docs, marked stable
Diffstat (limited to 'dev-ruby/narray/narray-0.5.7-r1.ebuild')
-rw-r--r--dev-ruby/narray/narray-0.5.7-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/narray/narray-0.5.7-r1.ebuild b/dev-ruby/narray/narray-0.5.7-r1.ebuild
new file mode 100644
index 000000000000..d067b522d806
--- /dev/null
+++ b/dev-ruby/narray/narray-0.5.7-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.5.7-r1.ebuild,v 1.1 2003/05/21 15:54:48 twp Exp $
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="http://www.ir.isas.ac.jp/~masa/ruby/dist/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="alpha arm hppa mips ppc sparc x86"
+DEPEND=">=dev-lang/ruby-1.6.8"
+
+src_compile() {
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ make exec_prefix=/usr DESTDIR=${D} install || die
+ dodoc ChangeLog README.* SPEC.*
+}