summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-15 07:19:57 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-15 07:19:57 +0000
commitc6852103d7d6352215af97fe68239808a98db591 (patch)
tree7180866187a67c06e54a8c573dbc201d40205837 /dev-ruby/rspec/rspec-2.12.0.ebuild
parentRun configure in src_configure. Remove unneeded || die. Whitespace. Split and... (diff)
downloadhistorical-c6852103d7d6352215af97fe68239808a98db591.tar.gz
historical-c6852103d7d6352215af97fe68239808a98db591.tar.bz2
historical-c6852103d7d6352215af97fe68239808a98db591.zip
Version bump.
Package-Manager: portage-2.1.11.31/cvs/Linux x86_64 Manifest-Sign-Key: 0x8883FA56A308A8D7!
Diffstat (limited to 'dev-ruby/rspec/rspec-2.12.0.ebuild')
-rw-r--r--dev-ruby/rspec/rspec-2.12.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/rspec/rspec-2.12.0.ebuild b/dev-ruby/rspec/rspec-2.12.0.ebuild
new file mode 100644
index 000000000000..49ce754ca4de
--- /dev/null
+++ b/dev-ruby/rspec/rspec-2.12.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-2.12.0.ebuild,v 1.1 2012/11/15 07:19:11 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(get_version_component_range 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-core-${SUBVERSION}*
+ =dev-ruby/rspec-expectations-${SUBVERSION}*
+ =dev-ruby/rspec-mocks-${SUBVERSION}*"