summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-04-22 01:07:15 +0000
committerAron Griffis <agriffis@gentoo.org>2002-04-22 01:07:15 +0000
commit9a990f653ca9c01cbe8024da19e94b056cb84ee1 (patch)
tree613e38ff115dc83554c8d5af32b38781cbc7a297 /dev-ruby/ruby-gconf
parentupdated package (diff)
downloadhistorical-9a990f653ca9c01cbe8024da19e94b056cb84ee1.tar.gz
historical-9a990f653ca9c01cbe8024da19e94b056cb84ee1.tar.bz2
historical-9a990f653ca9c01cbe8024da19e94b056cb84ee1.zip
Updated lots of ruby-gtk/gnome stuff. Modified ruby-gtk to use the
unified tarball so that all these other ebuilds can use the same tarball. This makes building easier, too, since the ruby-gtk header files are available for each ebuild (otherwise we'd have to install them).
Diffstat (limited to 'dev-ruby/ruby-gconf')
-rw-r--r--dev-ruby/ruby-gconf/ChangeLog23
-rw-r--r--dev-ruby/ruby-gconf/files/digest-ruby-gconf-0.21
-rw-r--r--dev-ruby/ruby-gconf/ruby-gconf-0.2.ebuild23
3 files changed, 39 insertions, 8 deletions
diff --git a/dev-ruby/ruby-gconf/ChangeLog b/dev-ruby/ruby-gconf/ChangeLog
index 893a56930874..da27416a6e77 100644
--- a/dev-ruby/ruby-gconf/ChangeLog
+++ b/dev-ruby/ruby-gconf/ChangeLog
@@ -1,13 +1,20 @@
# ChangeLog for dev-ruby/ruby-gconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gconf/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gconf/ChangeLog,v 1.2 2002/04/22 01:07:15 agriffis Exp $
+
+*ruby-gconf-0.2 (21 Apr 2002)
+
+ 21 Apr 2002; Aron Griffis <agriffis@gentoo.org> ruby-gconf-0.2.ebuild:
+
+ Updated to version 0.2
*ruby-gconf-0.1 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/dev-ruby/ruby-gconf/files/digest-ruby-gconf-0.2 b/dev-ruby/ruby-gconf/files/digest-ruby-gconf-0.2
new file mode 100644
index 000000000000..92384e091267
--- /dev/null
+++ b/dev-ruby/ruby-gconf/files/digest-ruby-gconf-0.2
@@ -0,0 +1 @@
+MD5 d9846c9821d7bc90d69acde6db548eb3 ruby-gconf-0.2.tar.gz 20135
diff --git a/dev-ruby/ruby-gconf/ruby-gconf-0.2.ebuild b/dev-ruby/ruby-gconf/ruby-gconf-0.2.ebuild
new file mode 100644
index 000000000000..51dfbb22eda9
--- /dev/null
+++ b/dev-ruby/ruby-gconf/ruby-gconf-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gconf/ruby-gconf-0.2.ebuild,v 1.1 2002/04/22 01:07:15 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Ruby Gconf bindings"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/${P}.tar.gz"
+HOMEPAGE="http://ruby-gnome.sourceforge.net/"
+
+DEPEND=">=dev-lang/ruby-1.6.4-r1
+ >=x11-libs/gtk+-1.2.10-r4
+ >=gnome-base/gconf-1.0.7-r2"
+
+src_compile() {
+ ruby extconf.rb || die "ruby extconf.rb failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make install DESTDIR=${D}
+ dodoc [A-Z]*
+}