summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-25 18:55:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-25 18:55:57 +0000
commitdf6e1c2310c700b61fbd8e7356c4fa567fe6b7a0 (patch)
tree0086e0c3fe74718e850d65ff3edea67048b84428 /dev-ruby/shotgun
parentAdd ~ia64 wrt #281056 (diff)
downloadhistorical-df6e1c2310c700b61fbd8e7356c4fa567fe6b7a0.tar.gz
historical-df6e1c2310c700b61fbd8e7356c4fa567fe6b7a0.tar.bz2
historical-df6e1c2310c700b61fbd8e7356c4fa567fe6b7a0.zip
Initial import of shotgun, a way to auto-relaod rackup servers.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/shotgun')
-rw-r--r--dev-ruby/shotgun/ChangeLog10
-rw-r--r--dev-ruby/shotgun/Manifest15
-rw-r--r--dev-ruby/shotgun/files/shotgun-0.5-optional-launchy.patch31
-rw-r--r--dev-ruby/shotgun/metadata.xml5
-rw-r--r--dev-ruby/shotgun/shotgun-0.5.ebuild45
5 files changed, 106 insertions, 0 deletions
diff --git a/dev-ruby/shotgun/ChangeLog b/dev-ruby/shotgun/ChangeLog
new file mode 100644
index 000000000000..00469528c9ca
--- /dev/null
+++ b/dev-ruby/shotgun/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/shotgun
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shotgun/ChangeLog,v 1.1 2010/01/25 18:55:56 flameeyes Exp $
+
+*shotgun-0.5 (25 Jan 2010)
+
+ 25 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org> +shotgun-0.5.ebuild,
+ +files/shotgun-0.5-optional-launchy.patch, +metadata.xml:
+ Initial import of shotgun, a way to auto-relaod rackup servers.
+
diff --git a/dev-ruby/shotgun/Manifest b/dev-ruby/shotgun/Manifest
new file mode 100644
index 000000000000..6a8fbd997f67
--- /dev/null
+++ b/dev-ruby/shotgun/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX shotgun-0.5-optional-launchy.patch 1030 RMD160 99202f5cf5e3a7484bcef934cbb2ac9cf8d1d32e SHA1 8b0db8bc5d9809c95eecc6b1dd892dabf14b8414 SHA256 869751dd6b7f2bddc30d51b5985afc84c9f9f3bf07cb3d19208c203af4e6287c
+DIST shotgun-git-0.5.tgz 5045 RMD160 a782a04b04d327afcc1aa7d87ccc12f28faa4431 SHA1 475cfc338ce99512aaa591a38519a7a9953166b5 SHA256 7ddad404bc0495ef27868e510f0858955251b0e5dc62b36b780bdc0922c958b1
+EBUILD shotgun-0.5.ebuild 1424 RMD160 b7eee2aeaff45cfbadb7780f0393bdaea5efe315 SHA1 d0d9ffd42913221aba7ad1bae2c6fc7aca19653f SHA256 8d35953b30df0e516f963ae89157e2b112bdadacfdbecc4feff5af37953087b9
+MISC ChangeLog 440 RMD160 d5dae7ef9154b7855a70d627ced4deddb6479486 SHA1 95d68cfa92ed9dbf0ff8f38b7fe2e06a1be8cb08 SHA256 eebd1bee60b98f23f7e1f6229b806195d1d995724a1900e25e863277398f46e9
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.14 (GNU/Linux)
+
+iEYEARECAAYFAktd6RwACgkQAiZjviIA2Xh+dACfbyawLdeNFcpfB1MOOKduu2+/
+s24An2dChW++sUGf0OeOinccawOH0a48
+=lw/9
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/shotgun/files/shotgun-0.5-optional-launchy.patch b/dev-ruby/shotgun/files/shotgun-0.5-optional-launchy.patch
new file mode 100644
index 000000000000..a060234a4299
--- /dev/null
+++ b/dev-ruby/shotgun/files/shotgun-0.5-optional-launchy.patch
@@ -0,0 +1,31 @@
+From 7d571983f5794f88c92560f1fc5061aa4ac12bac Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Mon, 25 Jan 2010 19:09:53 +0100
+Subject: [PATCH] Don't fail away if launchy could not be loaded.
+
+Since it's just a minor feature, make launchy optional this way.
+---
+ bin/shotgun | 8 ++++++--
+ 1 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/bin/shotgun b/bin/shotgun
+index d618d29..e12c4d8 100755
+--- a/bin/shotgun
++++ b/bin/shotgun
+@@ -137,7 +137,11 @@ server.run app, options do |inst|
+ puts "== Shotgun starting #{server.to_s} on http://#{options[:Host]}:#{options[:Port]}"
+
+ if browse
+- require 'launchy'
+- Launchy.open("http://#{options[:Host]}:#{options[:Port]}#{options[:Path]}")
++ begin
++ require 'launchy'
++ Launchy.open("http://#{options[:Host]}:#{options[:Port]}#{options[:Path]}")
++ rescue LoadError
++ $stderr.puts "Unable to load 'launchy', the browser won't be launched."
++ end
+ end
+ end
+--
+1.6.6.1
+
diff --git a/dev-ruby/shotgun/metadata.xml b/dev-ruby/shotgun/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/shotgun/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/shotgun/shotgun-0.5.ebuild b/dev-ruby/shotgun/shotgun-0.5.ebuild
new file mode 100644
index 000000000000..c01fd4117488
--- /dev/null
+++ b/dev-ruby/shotgun/shotgun-0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shotgun/shotgun-0.5.ebuild,v 1.1 2010/01/25 18:55:56 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Forking implementation of rackup"
+HOMEPAGE="http://rtomayko.github.com/shotgun/"
+
+GITHUB_USER="rtomayko"
+# Untagged, but should correspond to 0.5 release
+TREE_HASH="91f76ba3a75a22f60121b1403881aec70f35d75f"
+
+SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/${TREE_HASH} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/${GITHUB_USER}-${PN}-${TREE_HASH:0:7}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Warning: the code does not use gem versioning to make sure to load
+# only the right rack version so we might need to patch it to work :/
+# Has a runtime dependency over launchy, but it's not striclty needed,
+# so we'll patch it and announce its possible requirement.
+ruby_add_rdepend '=dev-ruby/rack-1.0*'
+ruby_add_bdepend test dev-ruby/bacon
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-optional-launchy.patch
+}
+
+pkg_postinst() {
+ elog "${PN} can also launch your browser at startup, but to do so it needs"
+ elog "the dev-ruby/launchy package that is currently available just on the Ruby"
+ elog "project's overlay for dependency/license issues."
+}