summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-14 00:18:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-14 00:18:33 +0000
commit9c6882386cc6711bb676b3e2fcc6c5783adbc60f (patch)
tree25f999f45c77527ae1f00db4455b7bf7315e8b1e /dev-ruby/tryouts
parentInitial import of attic needed ultimately for rudy. (diff)
downloadhistorical-9c6882386cc6711bb676b3e2fcc6c5783adbc60f.tar.gz
historical-9c6882386cc6711bb676b3e2fcc6c5783adbc60f.tar.bz2
historical-9c6882386cc6711bb676b3e2fcc6c5783adbc60f.zip
Initial import of tryouts, needed for attic (and other packages') tests.
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/tryouts')
-rw-r--r--dev-ruby/tryouts/ChangeLog10
-rw-r--r--dev-ruby/tryouts/files/tryouts-0.8.5-fixes.patch42
-rw-r--r--dev-ruby/tryouts/metadata.xml5
-rw-r--r--dev-ruby/tryouts/tryouts-0.8.5.ebuild35
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-ruby/tryouts/ChangeLog b/dev-ruby/tryouts/ChangeLog
new file mode 100644
index 000000000000..f4e6ed15d759
--- /dev/null
+++ b/dev-ruby/tryouts/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/tryouts
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tryouts/ChangeLog,v 1.1 2010/02/14 00:18:32 flameeyes Exp $
+
+*tryouts-0.8.5 (14 Feb 2010)
+
+ 14 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +tryouts-0.8.5.ebuild, +files/tryouts-0.8.5-fixes.patch, +metadata.xml:
+ Initial import of tryouts, needed for attic (and other packages') tests.
+
diff --git a/dev-ruby/tryouts/files/tryouts-0.8.5-fixes.patch b/dev-ruby/tryouts/files/tryouts-0.8.5-fixes.patch
new file mode 100644
index 000000000000..9add5279bf5e
--- /dev/null
+++ b/dev-ruby/tryouts/files/tryouts-0.8.5-fixes.patch
@@ -0,0 +1,42 @@
+Index: tryouts-0.8.5/lib/tryouts.rb
+===================================================================
+--- tryouts-0.8.5.orig/lib/tryouts.rb
++++ tryouts-0.8.5/lib/tryouts.rb
+@@ -2,10 +2,9 @@
+ require 'time'
+ require 'digest/sha1'
+
+-autoload :Attic, 'attic'
+-autoload :SysInfo, 'sysinfo'
+-autoload :OpenStruct, 'ostruct'
+-autoload :YAML, 'yaml'
++require 'attic'
++require 'sysinfo'
++require 'yaml'
+
+ ## NOTE: Don't require rye here so
+ ## we can still run tryouts on the
+Index: tryouts-0.8.5/Rakefile
+===================================================================
+--- tryouts-0.8.5.orig/Rakefile
++++ tryouts-0.8.5/Rakefile
+@@ -1,7 +1,6 @@
+ require 'rubygems'
+ require 'rake/clean'
+ require 'rake/gempackagetask'
+-require 'hanna/rdoctask'
+ require 'fileutils'
+ include FileUtils
+
+@@ -65,6 +64,11 @@ end
+
+
+ # RUBY DOCS TASK ==================================
++begin
++ require 'hanna/rdoctask'
++rescue LoadError
++ require 'rake/rdoctask'
++end
+
+ Rake::RDocTask.new do |t|
+ t.rdoc_dir = 'doc'
diff --git a/dev-ruby/tryouts/metadata.xml b/dev-ruby/tryouts/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/tryouts/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/tryouts/tryouts-0.8.5.ebuild b/dev-ruby/tryouts/tryouts-0.8.5.ebuild
new file mode 100644
index 000000000000..48cf70e26029
--- /dev/null
+++ b/dev-ruby/tryouts/tryouts-0.8.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tryouts/tryouts-0.8.5.ebuild,v 1.1 2010/02/14 00:18:32 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="High-level testing library (DSL) for Ruby codes and command-line applications"
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend dev-ruby/attic
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-fixes.patch
+}
+
+RESTRICT=test
+
+each_ruby_test() {
+ ${RUBY} -Ilib bin/sergeant || die "Tests failed"
+}