summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-28 08:24:41 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-28 08:24:41 +0000
commit92ea24f3b061aa99917a25d144921900b641016d (patch)
treefb161f34bd18890f4bd8057c97cf92d43e2e3d8f /dev-ruby
parentDrop ruby19 from stable version. (diff)
downloadhistorical-92ea24f3b061aa99917a25d144921900b641016d.tar.gz
historical-92ea24f3b061aa99917a25d144921900b641016d.tar.bz2
historical-92ea24f3b061aa99917a25d144921900b641016d.zip
Revision bump to drop ruby19 from stable version.
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-core/ChangeLog8
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.6.4-r1.ebuild73
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.6.4.ebuild4
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog8
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.6.0-r1.ebuild47
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild4
-rw-r--r--dev-ruby/rspec-mocks/ChangeLog8
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.6.0-r1.ebuild61
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild4
-rw-r--r--dev-ruby/rspec/ChangeLog8
-rw-r--r--dev-ruby/rspec/rspec-2.6.0-r1.ebuild28
-rw-r--r--dev-ruby/rspec/rspec-2.6.0.ebuild4
-rw-r--r--dev-ruby/sary-ruby/ChangeLog8
-rw-r--r--dev-ruby/sary-ruby/sary-ruby-1.2.0-r2.ebuild4
-rw-r--r--dev-ruby/sary-ruby/sary-ruby-1.2.0-r3.ebuild49
-rw-r--r--dev-ruby/tmail/ChangeLog8
-rw-r--r--dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild4
-rw-r--r--dev-ruby/tmail/tmail-1.2.7.1-r3.ebuild70
-rw-r--r--dev-ruby/tzinfo/ChangeLog8
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.31-r1.ebuild40
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.31.ebuild4
21 files changed, 431 insertions, 21 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index b6cdee4a09c1..be47f3a4ef7e 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.20 2011/10/02 17:05:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.21 2011/12/28 08:22:50 graaff Exp $
+
+*rspec-core-2.6.4-r1 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> rspec-core-2.6.4.ebuild,
+ +rspec-core-2.6.4-r1.ebuild:
+ Revision bump to drop ruby19 from stable version.
02 Oct 2011; Raúl Porcel <armin76@gentoo.org> rspec-core-2.6.4.ebuild:
ia64/sparc stable wrt #369573
diff --git a/dev-ruby/rspec-core/rspec-core-2.6.4-r1.ebuild b/dev-ruby/rspec-core/rspec-core-2.6.4-r1.ebuild
new file mode 100644
index 000000000000..38c6a7827e43
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-2.6.4-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.6.4-r1.ebuild,v 1.1 2011/12/28 08:22:50 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND} !<dev-ruby/rspec-1.3.1-r1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/nokogiri
+ dev-ruby/syntax
+ >=dev-ruby/zentest-4.4.1
+ dev-ruby/rspec-expectations:2
+ dev-ruby/rspec-mocks:2
+ )"
+
+# >=dev-ruby/cucumber-0.5.3
+# >=dev-ruby/autotest-4.2.9 -> zentest-4.4.1
+# dev-ruby/aruba"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # Also clean the /usr/lib/rubyee path (which is our own invention).
+ sed -i -e 's#lib\\d\*\\/ruby\\/#lib\\d*\\/ruby(ee|)\\/#' lib/rspec/core/configuration.rb || die
+
+ # Remove jruby-specific comparison documents since for us the normal
+ # version passes.
+ cp spec/rspec/core/formatters/html_formatted-1.8.7.html spec/rspec/core/formatters/html_formatted-1.8.7-jruby.html|| die
+ cp spec/rspec/core/formatters/text_mate_formatted-1.8.7.html spec/rspec/core/formatters/text_mate_formatted-1.8.7-jruby.html|| die
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ RUBYLIB="${S}/lib" rake rdoc || die "Unable to create documentation."
+ fi
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ # Run jruby's tests with the installed rspec script since
+ # otherwise files can't be found for some unknown reason.
+ RUBYLIB=${S}/lib ${RUBY} -S rspec --color spec || die "Tests failed."
+ ;;
+ *)
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die "Tests failed."
+ ;;
+ esac
+
+ # There are features but it seems as if these only work against a
+ # fully installed version.
+}
diff --git a/dev-ruby/rspec-core/rspec-core-2.6.4.ebuild b/dev-ruby/rspec-core/rspec-core-2.6.4.ebuild
index 2c7f7e8440c0..33498bb75d39 100644
--- a/dev-ruby/rspec-core/rspec-core-2.6.4.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-2.6.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.6.4.ebuild,v 1.8 2011/10/02 17:05:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.6.4.ebuild,v 1.9 2011/12/28 08:22:50 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_TEST="none"
RUBY_FAKEGEM_TASK_DOC="none"
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 76b097394058..c4a5b97c636b 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.18 2011/10/12 17:51:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.19 2011/12/28 08:21:30 graaff Exp $
+
+*rspec-expectations-2.6.0-r1 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org>
+ rspec-expectations-2.6.0.ebuild, +rspec-expectations-2.6.0-r1.ebuild:
+ Revision bump to drop ruby19 from stable version.
12 Oct 2011; Hans de Graaff <graaff@gentoo.org>
rspec-expectations-2.6.0.ebuild:
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.6.0-r1.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..e5ab1705ccaf
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.6.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.6.0-r1.ebuild,v 1.1 2011/12/28 08:21:30 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.2"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.4.0:2
+ dev-ruby/rspec-mocks:2
+ )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec-core:2 )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec
+
+ # There are features but they require aruba which we don't have yet.
+}
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild
index 2e5e482db244..3a083ac9d14b 100644
--- a/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild,v 1.9 2011/10/12 17:51:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.6.0.ebuild,v 1.10 2011/12/28 08:21:30 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_TEST="none"
diff --git a/dev-ruby/rspec-mocks/ChangeLog b/dev-ruby/rspec-mocks/ChangeLog
index d4273961bb76..ff4a9fe403a1 100644
--- a/dev-ruby/rspec-mocks/ChangeLog
+++ b/dev-ruby/rspec-mocks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-mocks
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.19 2011/10/02 17:01:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.20 2011/12/28 08:20:13 graaff Exp $
+
+*rspec-mocks-2.6.0-r1 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> rspec-mocks-2.6.0.ebuild,
+ +rspec-mocks-2.6.0-r1.ebuild:
+ Revision bump to drop ruby19 from stable version.
02 Oct 2011; Raúl Porcel <armin76@gentoo.org> rspec-mocks-2.6.0.ebuild:
ia64/sparc stable wrt #369573
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.6.0-r1.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..00397e2ec8c6
--- /dev/null
+++ b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.6.0-r1.ebuild,v 1.1 2011/12/28 08:20:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# cucumber and rspec-core are loaded unconditionally in the Rakefile,
+# so we also need to require them for USE=doc.
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.6.0:2
+ dev-ruby/rspec-expectations:2
+ )
+ doc? ( dev-ruby/rspec-core:2 )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ RUBYLIB="${S}/lib" rake rdoc || die
+ fi
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ # This particular failure is reported to be fixed in jruby 1.6.
+ ewarn "Tests disabled because they crash jruby."
+ ;;
+ *)
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die
+ ;;
+ esac
+
+ # There are features but they require aruba which we don't have yet.
+}
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild
index 5e014eca07ef..abf98587a6d3 100644
--- a/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild
+++ b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild,v 1.8 2011/10/02 17:01:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild,v 1.9 2011/12/28 08:20:13 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_TEST="none"
diff --git a/dev-ruby/rspec/ChangeLog b/dev-ruby/rspec/ChangeLog
index e7bedee83343..b5c7c36a3eec 100644
--- a/dev-ruby/rspec/ChangeLog
+++ b/dev-ruby/rspec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.110 2011/12/26 11:12:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.111 2011/12/28 08:24:41 graaff Exp $
+
+*rspec-2.6.0-r1 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> rspec-2.6.0.ebuild,
+ +rspec-2.6.0-r1.ebuild:
+ Revision bump to drop ruby19 from stable version.
26 Dec 2011; Hans de Graaff <graaff@gentoo.org> rspec-1.3.2.ebuild:
Fix tests for ruby19. Should also fix bug 340781.
diff --git a/dev-ruby/rspec/rspec-2.6.0-r1.ebuild b/dev-ruby/rspec/rspec-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..6a3310b8223b
--- /dev/null
+++ b/dev-ruby/rspec/rspec-2.6.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-2.6.0-r1.ebuild,v 1.1 2011/12/28 08:24:41 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(get_version_component_range 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-core-${SUBVERSION}*
+ =dev-ruby/rspec-expectations-${SUBVERSION}*
+ =dev-ruby/rspec-mocks-${SUBVERSION}*"
diff --git a/dev-ruby/rspec/rspec-2.6.0.ebuild b/dev-ruby/rspec/rspec-2.6.0.ebuild
index 07aed9ed7a00..7b7a560d349a 100644
--- a/dev-ruby/rspec/rspec-2.6.0.ebuild
+++ b/dev-ruby/rspec/rspec-2.6.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-2.6.0.ebuild,v 1.10 2011/10/02 17:07:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-2.6.0.ebuild,v 1.11 2011/12/28 08:24:41 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 ree18 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_TEST=""
diff --git a/dev-ruby/sary-ruby/ChangeLog b/dev-ruby/sary-ruby/ChangeLog
index 0caaa46d7a50..28f4dfa338cc 100644
--- a/dev-ruby/sary-ruby/ChangeLog
+++ b/dev-ruby/sary-ruby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/sary-ruby
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sary-ruby/ChangeLog,v 1.43 2011/12/03 19:04:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sary-ruby/ChangeLog,v 1.44 2011/12/28 08:17:26 graaff Exp $
+
+*sary-ruby-1.2.0-r3 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> sary-ruby-1.2.0-r2.ebuild,
+ +sary-ruby-1.2.0-r3.ebuild:
+ Revision bump to drop ruby19 from stable version.
03 Dec 2011; Markos Chandras <hwoarang@gentoo.org> sary-ruby-1.2.0-r2.ebuild:
Stable on amd64 wrt bug #391587
diff --git a/dev-ruby/sary-ruby/sary-ruby-1.2.0-r2.ebuild b/dev-ruby/sary-ruby/sary-ruby-1.2.0-r2.ebuild
index ec067b930850..5d980851b1d8 100644
--- a/dev-ruby/sary-ruby/sary-ruby-1.2.0-r2.ebuild
+++ b/dev-ruby/sary-ruby/sary-ruby-1.2.0-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sary-ruby/sary-ruby-1.2.0-r2.ebuild,v 1.3 2011/12/03 19:04:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sary-ruby/sary-ruby-1.2.0-r2.ebuild,v 1.4 2011/12/28 08:17:26 graaff Exp $
EAPI="2"
# jruby: mkmf issue
-USE_RUBY="ruby18 ree18 ruby19"
+USE_RUBY="ruby18 ree18"
inherit ruby-ng
DESCRIPTION="Ruby Binding of Sary"
diff --git a/dev-ruby/sary-ruby/sary-ruby-1.2.0-r3.ebuild b/dev-ruby/sary-ruby/sary-ruby-1.2.0-r3.ebuild
new file mode 100644
index 000000000000..fcd3247eb947
--- /dev/null
+++ b/dev-ruby/sary-ruby/sary-ruby-1.2.0-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sary-ruby/sary-ruby-1.2.0-r3.ebuild,v 1.1 2011/12/28 08:17:26 graaff Exp $
+
+EAPI="2"
+# jruby: mkmf issue
+USE_RUBY="ruby18 ree18 ruby19"
+inherit ruby-ng
+
+DESCRIPTION="Ruby Binding of Sary"
+HOMEPAGE="http://sary.sourceforge.net/"
+SRC_URI="http://sary.sourceforge.net/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-text/sary-1.2.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+RUBY_PATCHES=(
+ "${P}-gentoo.patch"
+ "${P}-ruby19.patch"
+)
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ # We have injected --no-undefined in Ruby as a safety precaution
+ # against broken ebuilds, but the Ruby-Gnome bindings
+ # unfortunately rely on the lazy load of other extensions; see bug
+ # #320545.
+ find . -name Makefile -print0 | xargs -0 \
+ sed -i -e 's:-Wl,--no-undefined ::' || die "--no-undefined removal failed"
+
+ emake || die "emake failed"
+}
+
+each_ruby_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
+
+all_ruby_install() {
+ dodoc ChangeLog *.rd || die
+}
diff --git a/dev-ruby/tmail/ChangeLog b/dev-ruby/tmail/ChangeLog
index 8b412a86db1e..d0c1a58982ce 100644
--- a/dev-ruby/tmail/ChangeLog
+++ b/dev-ruby/tmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tmail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/ChangeLog,v 1.20 2011/07/24 17:41:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/ChangeLog,v 1.21 2011/12/28 08:15:56 graaff Exp $
+
+*tmail-1.2.7.1-r3 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> tmail-1.2.7.1-r2.ebuild,
+ +tmail-1.2.7.1-r3.ebuild:
+ Revision bump to drop ruby19 from stable version.
24 Jul 2011; Raúl Porcel <armin76@gentoo.org> tmail-1.2.7.1-r2.ebuild:
ia64/sparc stable
diff --git a/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild b/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild
index 63ff10a27f4c..7561c6981c99 100644
--- a/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild
+++ b/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild,v 1.7 2011/07/24 17:41:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/tmail-1.2.7.1-r2.ebuild,v 1.8 2011/12/28 08:15:56 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
RUBY_FAKEGEM_TASK_DOC="doc"
RUBY_FAKEGEM_DOCDIR="doc"
diff --git a/dev-ruby/tmail/tmail-1.2.7.1-r3.ebuild b/dev-ruby/tmail/tmail-1.2.7.1-r3.ebuild
new file mode 100644
index 000000000000..67a411405f65
--- /dev/null
+++ b/dev-ruby/tmail/tmail-1.2.7.1-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tmail/tmail-1.2.7.1-r3.ebuild,v 1.1 2011/12/28 08:15:56 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README CHANGES NOTES"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An email handling library"
+HOMEPAGE="http://rubyforge.org/projects/tmail/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+# Tests seem to be broken with the new encoding handling from Ruby,
+# need to be verified twice; code seems to work anyway.
+RESTRICT=test
+
+# Once it's added to portage, this should be added, right now it's
+# bundled.
+# ruby_add_rdepend dev-ruby/rchardet
+
+ruby_add_bdepend "
+ dev-ruby/racc
+ test? ( >=dev-ruby/mocha-0.9.5 )"
+
+all_ruby_prepare() {
+ # Provide file that is no longer distributed but still needed
+ mkdir meta || die "Failed to mkdir meta."
+ echo "tmail" > meta/unixname || die "Failed to create unixname file."
+}
+
+each_ruby_configure() {
+ case ${RUBY} in
+ *ruby18 | *rubyee18)
+ ${RUBY} -Cext/tmailscanner/tmail extconf.rb || die "extconf failed"
+ ;;
+ esac
+}
+
+each_ruby_compile() {
+ emake -C lib/tmail $(use debug && echo DEBUG=true) parser.rb || die "emake failed"
+
+ case ${RUBY} in
+ *ruby18 | *rubyee18)
+ emake -Cext/tmailscanner/tmail \
+ CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake extension failed"
+ ;;
+ esac
+}
+
+each_ruby_install() {
+ # We cannot use the recursive install because there are
+ # racc source files and a makefile.
+ find lib -name '*.rb' | while read file; do
+ ruby_fakegem_newins $file $file
+ done
+
+ [[ -f ext/tmailscanner/tmail/tmailscanner.so ]] && \
+ ruby_fakegem_newins ext/tmailscanner/tmail/tmailscanner.so lib/tmail/tmailscanner.so
+
+ ruby_fakegem_install_gemspec
+}
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 8e555dcdcc44..1bcccdd95509 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.94 2011/12/28 08:10:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.95 2011/12/28 08:14:14 graaff Exp $
+
+*tzinfo-0.3.31-r1 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> tzinfo-0.3.31.ebuild,
+ +tzinfo-0.3.31-r1.ebuild:
+ Revision bump to drop ruby19 from stable version.
28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -tzinfo-0.3.30.ebuild:
Remove old version.
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.31-r1.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.31-r1.ebuild
new file mode 100644
index 000000000000..a7386eaafa49
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.31-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.31-r1.ebuild,v 1.1 2011/12/28 08:14:14 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+# No longer compatible with rake 0.9 starting with 0.3.31.
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild
index 7ad009f09248..673a3f4712c5 100644
--- a/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild
+++ b/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild,v 1.5 2011/12/18 15:52:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild,v 1.6 2011/12/28 08:14:14 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
# No longer compatible with rake 0.9 starting with 0.3.31.
RUBY_FAKEGEM_TASK_DOC=""