summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-14 15:53:58 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-14 15:53:58 +0000
commit5bd3830de8c752c9ca59670e68b83eafc780f297 (patch)
tree8094eb559b1a5f95b2d9dafd20295c026e73a4ba /dev-scheme/guile
parentAutomated update of use.local.desc (diff)
downloadhistorical-5bd3830de8c752c9ca59670e68b83eafc780f297.tar.gz
historical-5bd3830de8c752c9ca59670e68b83eafc780f297.tar.bz2
historical-5bd3830de8c752c9ca59670e68b83eafc780f297.zip
Imported prefix changes
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'dev-scheme/guile')
-rw-r--r--dev-scheme/guile/ChangeLog8
-rw-r--r--dev-scheme/guile/files/guile-1.8.6-interix.patch20
-rw-r--r--dev-scheme/guile/guile-1.8.7-r2.ebuild118
3 files changed, 145 insertions, 1 deletions
diff --git a/dev-scheme/guile/ChangeLog b/dev-scheme/guile/ChangeLog
index 963cb0ad08b7..866a0aeb7895 100644
--- a/dev-scheme/guile/ChangeLog
+++ b/dev-scheme/guile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-scheme/guile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.79 2010/09/24 16:34:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/ChangeLog,v 1.80 2010/11/14 15:53:58 jlec Exp $
+
+*guile-1.8.7-r2 (14 Nov 2010)
+
+ 14 Nov 2010; Justin Lecher <jlec@gentoo.org>
+ +files/guile-1.8.6-interix.patch, +guile-1.8.7-r2.ebuild:
+ Imported prefix changes
*guile-1.8.7-r1 (24 Sep 2010)
diff --git a/dev-scheme/guile/files/guile-1.8.6-interix.patch b/dev-scheme/guile/files/guile-1.8.6-interix.patch
new file mode 100644
index 000000000000..08777b3a84e9
--- /dev/null
+++ b/dev-scheme/guile/files/guile-1.8.6-interix.patch
@@ -0,0 +1,20 @@
+diff -ru guile-1.8.6.orig/libguile/iselect.h guile-1.8.6/libguile/iselect.h
+--- guile-1.8.6.orig/libguile/iselect.h 2009-09-25 13:44:23 +0200
++++ guile-1.8.6/libguile/iselect.h 2009-09-25 13:45:36 +0200
+@@ -38,7 +38,16 @@
+ #ifdef FD_SET
+
+ #define SELECT_TYPE fd_set
++#ifdef __INTERIX
++// interix' FD_SETSIZE should be == OPEN_MAX, but it seems
++// that there is an error in the headers, which makes it
++// four times as big, and thus causes errno 22 on select
++// (invalid argument).
++#include <limits.h>
++#define SELECT_SET_SIZE OPEN_MAX
++#else
+ #define SELECT_SET_SIZE FD_SETSIZE
++#endif
+
+ #else /* no FD_SET */
+
diff --git a/dev-scheme/guile/guile-1.8.7-r2.ebuild b/dev-scheme/guile/guile-1.8.7-r2.ebuild
new file mode 100644
index 000000000000..c17edc8c3829
--- /dev/null
+++ b/dev-scheme/guile/guile-1.8.7-r2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/guile/guile-1.8.7-r2.ebuild,v 1.1 2010/11/14 15:53:58 jlec Exp $
+
+EAPI=3
+inherit eutils autotools flag-o-matic elisp-common
+
+DESCRIPTION="Scheme interpreter"
+HOMEPAGE="http://www.gnu.org/software/guile/"
+SRC_URI="mirror://gnu/guile/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="networking +regex discouraged +deprecated elisp emacs nls debug-freelist debug-malloc debug +threads"
+RESTRICT="!regex? ( test )"
+
+DEPEND="
+ >=dev-libs/gmp-4.1
+ >=sys-devel/libtool-1.5.6
+ sys-devel/gettext
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
+# but there are lots of collisions. Most in /usr/share/libguile. Therefore
+# I'm slotting this in the same slot as guile-1.6* for now.
+SLOT="12"
+MAJOR="1.8"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.6-interix.patch
+
+ sed "s_sleep 999_sleep 1_" -i test-suite/tests/popen.test
+ epatch "${FILESDIR}/${P}-fix_tests.patch"
+ epatch "${FILESDIR}"/${P}-gcc45.patch # 317175
+
+# cp configure.in configure.in.old
+
+ #for libtool-2.2*, bug 212723
+# sed 's/AC_CONFIG_MACRO_DIR(\[m4\])/AC_CONFIG_MACRO_DIR(\[guile-config\])/' -i configure.in
+
+# diff -u configure.in.old configure.in
+
+ eautoreconf
+}
+
+src_configure() {
+ # see bug #178499
+ filter-flags -ftree-vectorize
+
+ #will fail for me if posix is disabled or without modules -- hkBst
+ econf \
+ --disable-error-on-warning \
+ --disable-static \
+ --enable-posix \
+ $(use_enable networking) \
+ $(use_enable regex) \
+ $(use deprecated || use_enable discouraged) \
+ $(use_enable deprecated) \
+ $(use_enable elisp) \
+ $(use_enable nls) \
+ --disable-rpath \
+ $(use_enable debug-freelist) \
+ $(use_enable debug-malloc) \
+ $(use_enable debug guile-debug) \
+ $(use_with threads) \
+ --with-modules \
+ EMACS=no
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ # Above we have disabled the build system's Emacs support;
+ # for USE=emacs we compile (and install) the files manually
+ if use emacs; then
+ cd emacs
+ elisp-compile *.el || die
+ fi
+}
+
+src_install() {
+ einstall || die "install failed"
+
+ dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README THANKS || die
+
+ # texmacs needs this, closing bug #23493
+ dodir /etc/env.d
+ echo "GUILE_LOAD_PATH=\"${EPREFIX}/usr/share/guile/${MAJOR}\"" > "${ED}"/etc/env.d/50guile
+
+ # necessary for registering slib, see bug 206896
+ keepdir /usr/share/guile/site
+
+ if use emacs; then
+ elisp-install ${PN} emacs/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" || die
+ fi
+}
+
+pkg_postinst() {
+ [ "${EROOT}" == "/" ] && pkg_config
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
+
+pkg_config() {
+ if has_version dev-scheme/slib; then
+ einfo "Registering slib with guile"
+ install_slib_for_guile
+ fi
+}
+
+_pkg_prerm() {
+ rm -f "${EROOT}"/usr/share/guile/site/slibcat
+}