summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Bonazzola <sanchan@gentoo.org>2006-01-24 19:18:02 +0000
committerSandro Bonazzola <sanchan@gentoo.org>2006-01-24 19:18:02 +0000
commite1c32af009db6d3b316d2f2bf10fef1ed8ae4569 (patch)
tree202d9e9ba7587b5e06a666bafd350cf305deff99 /dev-tinyos/serial-forwarder/serial-forwarder-1.1.15.ebuild
parentAdd support for USE_ORDER (diff)
downloadhistorical-e1c32af009db6d3b316d2f2bf10fef1ed8ae4569.tar.gz
historical-e1c32af009db6d3b316d2f2bf10fef1ed8ae4569.tar.bz2
historical-e1c32af009db6d3b316d2f2bf10fef1ed8ae4569.zip
Initial import of serial-forwarder for TinyOS.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-tinyos/serial-forwarder/serial-forwarder-1.1.15.ebuild')
-rw-r--r--dev-tinyos/serial-forwarder/serial-forwarder-1.1.15.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-tinyos/serial-forwarder/serial-forwarder-1.1.15.ebuild b/dev-tinyos/serial-forwarder/serial-forwarder-1.1.15.ebuild
new file mode 100644
index 000000000000..1f0d5eb9197d
--- /dev/null
+++ b/dev-tinyos/serial-forwarder/serial-forwarder-1.1.15.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/serial-forwarder/serial-forwarder-1.1.15.ebuild,v 1.1 2006/01/24 19:18:02 sanchan Exp $
+
+inherit toolchain-funcs
+
+CVS_MONTH="Dec"
+CVS_YEAR="2005"
+MY_P="tinyos"
+
+DESCRIPTION="A serial forwarder for TinyOS"
+HOMEPAGE="http://www.tinyos.net/"
+SRC_URI="http://www.tinyos.net/dist-1.1.0/tinyos/source/${MY_P}-${PV}${CVS_MONTH}${CVS_YEAR}cvs.tar.gz"
+LICENSE="Intel"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+S=${WORKDIR}/${MY_P}-${PV}${CVS_MONTH}${CVS_YEAR}cvs/tools/src/sf
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -o sf sf.c serialsource.c sfsource.c platform.c || die "sf compile failed"
+ $(tc-getCC) ${CFLAGS} -o sflisten sflisten.c sfsource.c platform.c || die "sflisten compile failed"
+
+ # I'm not sure what to do with asf for arm. It seems just sf compiled for arm.
+ # But it has no much sense build it if it can't run on the system.
+ # If you use this on arm, please contact the maintainer.
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe sf sflisten || die "install failed"
+}