summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2003-01-24 15:04:07 +0000
committerBart Verwilst <verwilst@gentoo.org>2003-01-24 15:04:07 +0000
commitf25d0a4299ce93d8041e6734f70ea53f0fa28cc0 (patch)
tree3b3d9b530326e1434e16ff4ba2bcb564ff053cbf /dev-util/ccache
parentadded ~ppc (diff)
downloadhistorical-f25d0a4299ce93d8041e6734f70ea53f0fa28cc0.tar.gz
historical-f25d0a4299ce93d8041e6734f70ea53f0fa28cc0.tar.bz2
historical-f25d0a4299ce93d8041e6734f70ea53f0fa28cc0.zip
new version in unstable
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog6
-rw-r--r--dev-util/ccache/ccache-2.1.1.ebuild51
-rw-r--r--dev-util/ccache/files/digest-ccache-2.1.11
3 files changed, 57 insertions, 1 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index ae2f5bb1c35a..875073650cd3 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/ccache
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.11 2003/01/06 21:49:35 tuxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.12 2003/01/24 15:04:07 verwilst Exp $
+
+*ccache-2.1.1 (24 Jan 2002)
+
+ 24 Jan 2002; Bart Verwilst <verwilst@gentoo.org> : updating to 2.1.1.
06 Jan 2003; Jan Seidel <tuxus@gentoo.org>: ccache-1.9-r1.ebuild,
Added mips to keywords.
diff --git a/dev-util/ccache/ccache-2.1.1.ebuild b/dev-util/ccache/ccache-2.1.1.ebuild
new file mode 100644
index 000000000000..0fc9420c8573
--- /dev/null
+++ b/dev-util/ccache/ccache-2.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.1.1.ebuild,v 1.1 2003/01/24 15:04:07 verwilst Exp $
+
+DESCRIPTION="ccache is a fast compiler cache. It is used as a front end to your
+compiler to safely cache compilation output. When the same code is compiled
+again the cached output is used giving a significant speedup."
+SRC_URI="http://ccache.samba.org/ftp/ccache/${P}.tar.gz"
+HOMEPAGE="http://ccache.samba.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+# Note: this version is designed to be auto-detected and used if
+# you happen to have Portage 2.0.6+ installed.
+
+src_compile() {
+ ./configure --prefix=${D}/usr || die
+ make || die
+}
+
+src_install () {
+ exeinto /usr/bin/ccache
+ doexe ccache
+ doman ccache.1
+ dodoc COPYING README
+}
+
+pkg_postinst() {
+ cd /usr/bin/ccache
+
+ # Search the PATH now that gcc doesn't live in /usr/bin
+ einfo "Scanning for compiler front-ends"
+ for a in gcc cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++; do
+ type -ap ${a} && ln -sf ccache ${a}
+ done
+
+ if [ ! -d ${ROOT}root/.ccache ]
+ then
+ install -d -m0700 ${ROOT}root/.ccache
+ fi
+
+ einfo "To use ccache with **non-Portage** C compiling, add"
+ einfo "/usr/bin/ccache to your path before /usr/bin. Portage 2.0.6+"
+ einfo "will automatically take advantage of ccache with no additional"
+ einfo "steps. If this is your first install of ccache, type something"
+ einfo "like this to set a maximum cache size of 2GB (or whatever you"
+ einfo "desire):"
+ einfo "# /usr/bin/ccache/ccache -M 2G"
+}
diff --git a/dev-util/ccache/files/digest-ccache-2.1.1 b/dev-util/ccache/files/digest-ccache-2.1.1
new file mode 100644
index 000000000000..20fb0b9e7dc7
--- /dev/null
+++ b/dev-util/ccache/files/digest-ccache-2.1.1
@@ -0,0 +1 @@
+MD5 0d1f3cd50556effcc0e50565dc2ab345 ccache-2.1.1.tar.gz 78121