summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2009-05-20 03:13:16 +0000
committerRyan Hill <rhill@gentoo.org>2009-05-20 03:13:16 +0000
commit6553b961a2e0d26208d3ead052e0d5c0c2fa1f0e (patch)
tree7c49594859caa2cdb968f652f72cf608745dedc6 /dev-util/ddd/ddd-3.3.12-r1.ebuild
parentAllow init script to find homedir instead of hardcoding it, patch by Michał ... (diff)
downloadhistorical-6553b961a2e0d26208d3ead052e0d5c0c2fa1f0e.tar.gz
historical-6553b961a2e0d26208d3ead052e0d5c0c2fa1f0e.tar.bz2
historical-6553b961a2e0d26208d3ead052e0d5c0c2fa1f0e.zip
Revision bump.
- fix building with GCC 4.4 - depend on x11-libs/xfontsel, tweak the rest - use Gnu mirror and change LICENSE to [L]GPL-3 - rewrite src_install Maintainer needed. Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-util/ddd/ddd-3.3.12-r1.ebuild')
-rw-r--r--dev-util/ddd/ddd-3.3.12-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/ddd/ddd-3.3.12-r1.ebuild b/dev-util/ddd/ddd-3.3.12-r1.ebuild
new file mode 100644
index 000000000000..79c5a653161f
--- /dev/null
+++ b/dev-util/ddd/ddd-3.3.12-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ddd-3.3.12-r1.ebuild,v 1.1 2009/05/20 03:13:15 dirtyepic Exp $
+
+inherit eutils
+
+DESCRIPTION="Graphical openmotif front-end for command-line debuggers"
+HOMEPAGE="http://www.gnu.org/software/ddd"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3 LGPL-3 FDL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-devel/gdb-6.5
+ >=x11-libs/openmotif-2.3
+ x11-libs/libX11
+ x11-libs/libXp"
+
+RDEPEND="${DEPEND}
+ sci-visualization/gnuplot
+ x11-apps/xfontsel"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
+src_compile() {
+ econf || die
+
+ cd "${S}"/ddd
+ emake version.h build.h host.h root.h configinfo.C Ddd.ad.h || die "Failed to build headers"
+
+ cd "${S}"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS CREDITS INSTALL NEWS PROBLEMS README TIPS TODO
+ cp -R "${S}"/doc/* "${D}"/usr/share/doc/${PF}
+
+ insinto /usr/share/pixmaps
+ doins "${S}"/icons/ddd.xpm
+}