summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-03 17:47:44 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-03 17:47:44 +0000
commitd9269dfb7e96fda5966c0cf4208844c99ca4666a (patch)
treeec6662566c6ee62dbc1015cc6fc0e241022ab6c6 /dev-util/glade
parentUpgrade to latest version of HTML-Tagset. (diff)
downloadhistorical-d9269dfb7e96fda5966c0cf4208844c99ca4666a.tar.gz
historical-d9269dfb7e96fda5966c0cf4208844c99ca4666a.tar.bz2
historical-d9269dfb7e96fda5966c0cf4208844c99ca4666a.zip
Added dependencies
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/glade-0.5.9.ebuild24
1 files changed, 20 insertions, 4 deletions
diff --git a/dev-util/glade/glade-0.5.9.ebuild b/dev-util/glade/glade-0.5.9.ebuild
index 3bf9e2358beb..a7cfee7a73b9 100644
--- a/dev-util/glade/glade-0.5.9.ebuild
+++ b/dev-util/glade/glade-0.5.9.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-0.5.9.ebuild,v 1.4 2000/10/14 11:32:53 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-0.5.9.ebuild,v 1.5 2000/11/03 17:47:44 achim Exp $
P=glade-0.5.9
A=${P}.tar.gz
@@ -10,17 +10,33 @@ DESCRIPTION="glade"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/glade/"${A}
HOMEPAGE="http://www.gnome.org/"
+DEPEND=">=x11-libs/gtk+-1.2.8
+ gnome? ( >=gnome-base/gnome-libs-1.2.4 )"
+
src_compile() {
cd ${S}
- try ./configure --host=${CHOST} --prefix=/opt/gnome --with-catgets \
- --disable-gnome-db
+ local myopts
+ if [ -n "`use gnome`" ]
+ then
+ echo "Using Gnome"
+ myopts="--prefix=/opt/gnome --disable-gnome-db"
+ else
+ myopts="--prefix=/usr/X11R6 --disable-gnome"
+ fi
+ try ./configure --host=${CHOST} --with-catgets ${myopts}
# bonobo support does not work yet
try make
}
src_install() {
cd ${S}
- try make prefix=${D}/opt/gnome install
+ local myopts
+ if [ -n "`use gnome`" ]
+ then
+ try make prefix=${D}/opt/gnome install
+ else
+ try make prefix=${D}/usr/X11R6 install
+ fi
dodoc AUTHORS COPYING* FAQ NEWS
dodoc README* TODO
}