summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-04 12:17:54 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-04 12:17:54 +0000
commit3924c1a62d2fce05ebb7ec00793021bf9f32ce84 (patch)
treefe28af2e3d4b058177ced256e30e783cd1a85981 /dev-util/sourcenav/sourcenav-5.1.1.ebuild
parentmove line that prints current patch to after exclusion of the internal-compil... (diff)
downloadhistorical-3924c1a62d2fce05ebb7ec00793021bf9f32ce84.tar.gz
historical-3924c1a62d2fce05ebb7ec00793021bf9f32ce84.tar.bz2
historical-3924c1a62d2fce05ebb7ec00793021bf9f32ce84.zip
Version bump and rename
Diffstat (limited to 'dev-util/sourcenav/sourcenav-5.1.1.ebuild')
-rw-r--r--dev-util/sourcenav/sourcenav-5.1.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/sourcenav/sourcenav-5.1.1.ebuild b/dev-util/sourcenav/sourcenav-5.1.1.ebuild
new file mode 100644
index 000000000000..9bb947f1875e
--- /dev/null
+++ b/dev-util/sourcenav/sourcenav-5.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sourcenav/sourcenav-5.1.1.ebuild,v 1.1 2002/11/04 12:17:54 aliz Exp $
+
+S=${WORKDIR}/build
+
+DESCRIPTION="Source-Navigator is a source code analysis tool"
+SRC_URI="mirror://sourceforge/sourcenav/${P}.tar.gz"
+HOMEPAGE="http://sourcenav.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~x86 ~sparc ~sparc64"
+DEPEND=">=sys-libs/glibc-2.2.4"
+SN="/usr/snavigator"
+
+src_unpack() {
+ mkdir build
+ unpack ${A}
+
+ cd ${WORKDIR}/${P}
+
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+
+}
+
+src_compile() {
+ ../${P}/configure \
+ --host=${CHOST} \
+ --prefix=${SN} \
+ --mandir=${SN}/share/man \
+ --infodir=${SN}/share/info \
+ --datadir=${SN}/share || die
+
+ make all-snavigator || die
+}
+
+src_install () {
+ make DESTDIR=${D} \
+ install-snavigator || die
+
+ chmod -Rf 755 ${D}/usr/share/doc/${P}/demos
+ mkdir -p ${D}/etc/env.d
+ echo "PATH=/usr/snavigator/bin" > ${D}/etc/env.d/10snavigator
+}