summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2007-02-07 09:07:10 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2007-02-07 09:07:10 +0000
commit6807cacfd5b4ff0028fc386be59c7583ebf0dceb (patch)
tree790abb493829802c494288e1a3cf002421eef44a /dev-util/stgit/stgit-0.12.ebuild
parentcleanup (diff)
downloadhistorical-6807cacfd5b4ff0028fc386be59c7583ebf0dceb.tar.gz
historical-6807cacfd5b4ff0028fc386be59c7583ebf0dceb.tar.bz2
historical-6807cacfd5b4ff0028fc386be59c7583ebf0dceb.zip
New upstream version
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'dev-util/stgit/stgit-0.12.ebuild')
-rw-r--r--dev-util/stgit/stgit-0.12.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/stgit/stgit-0.12.ebuild b/dev-util/stgit/stgit-0.12.ebuild
new file mode 100644
index 000000000000..eecf366b7add
--- /dev/null
+++ b/dev-util/stgit/stgit-0.12.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/stgit-0.12.ebuild,v 1.1 2007/02/07 09:07:10 ferdy Exp $
+
+inherit distutils
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+SRC_URI="http://homepage.ntlworld.com/cmarinas/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-util/git-1.4.3"
+
+src_install() {
+ sed -i -e 's-\(prefix:\) ~-\1 /usr-' setup.cfg
+ distutils_src_install
+ dodir /usr/share/doc/${PF}
+ mv ${D}/usr/share/${PN}/examples ${D}/usr/share/doc/${PF}
+ rmdir ${D}/usr/share/doc/${PN}
+}