summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-02-28 22:55:43 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-02-28 22:55:43 +0000
commit87b45d2e78b021fbc83f826df19fcb489fac64b8 (patch)
tree4e14cda2873ab11f229411c4e67013b64dc59206 /dev-util/xxdiff/xxdiff-2.5.ebuild
parentAdded required env var to /etc/env.d (diff)
downloadhistorical-87b45d2e78b021fbc83f826df19fcb489fac64b8.tar.gz
historical-87b45d2e78b021fbc83f826df19fcb489fac64b8.tar.bz2
historical-87b45d2e78b021fbc83f826df19fcb489fac64b8.zip
upgraded to latest version
Diffstat (limited to 'dev-util/xxdiff/xxdiff-2.5.ebuild')
-rw-r--r--dev-util/xxdiff/xxdiff-2.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/xxdiff/xxdiff-2.5.ebuild b/dev-util/xxdiff/xxdiff-2.5.ebuild
new file mode 100644
index 000000000000..a17b190a4fda
--- /dev/null
+++ b/dev-util/xxdiff/xxdiff-2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xxdiff/xxdiff-2.5.ebuild,v 1.1 2002/02/28 22:55:43 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A graphical file comparator and merge tool simular to xdiff."
+SRC_URI="http://prdownloads.sourceforge.net/xxdiff/${P}.tar.gz"
+HOMEPAGE="http://xxdiff.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ =x11-libs/qt-2.3*
+ >=dev-util/tmake-1.8-r1
+ >=sys-devel/gcc-2.95.3"
+
+RDEPEND="sys-apps/diffutils"
+
+src_compile() {
+ export QTDIR=/usr/qt/2
+ cd src
+ tmake -o Makefile xxdiff.pro
+
+ emake || die
+}
+
+src_install () {
+ dobin src/xxdiff
+ newman src/xxdiff.man xxdiff.1
+ dodoc README COPYING CHANGES TODO
+ dodoc copyright.txt doc/xxdiff-doc.sgml
+}
+
+# vim: ai et sw=4 ts=4