summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-17 06:45:56 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-17 06:45:56 +0000
commit02bbc40d6317a6b9ce0ae70d837034be66973514 (patch)
tree95cd56422542646120e1f2825ca09a4b6799b0ec /dev-util
parentremove hunk that doesnt matter (diff)
downloadhistorical-02bbc40d6317a6b9ce0ae70d837034be66973514.tar.gz
historical-02bbc40d6317a6b9ce0ae70d837034be66973514.tar.bz2
historical-02bbc40d6317a6b9ce0ae70d837034be66973514.zip
Version bump.
Package-Manager: portage-2.1.2
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/ChangeLog9
-rw-r--r--dev-util/strace/files/digest-strace-4.5.153
-rw-r--r--dev-util/strace/strace-4.5.15.ebuild49
3 files changed, 59 insertions, 2 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 13f09f829cd8..9269b41f824b 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/strace
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.92 2006/12/02 20:35:58 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.93 2007/01/17 06:45:56 vapier Exp $
+
+*strace-4.5.15 (17 Jan 2007)
+
+ 17 Jan 2007; Mike Frysinger <vapier@gentoo.org> +strace-4.5.15.ebuild:
+ Version bump.
02 Dec 2006; Mike Frysinger <vapier@gentoo.org>
+files/strace-4.5.14-CTL_PROC.patch, strace-4.5.14.ebuild:
diff --git a/dev-util/strace/files/digest-strace-4.5.15 b/dev-util/strace/files/digest-strace-4.5.15
new file mode 100644
index 000000000000..bf58fb345d1b
--- /dev/null
+++ b/dev-util/strace/files/digest-strace-4.5.15
@@ -0,0 +1,3 @@
+MD5 ef40944118841803391d212cb64d3c5b strace-4.5.15.tar.bz2 455607
+RMD160 0c6aaa8820a0985d89b21a5da9578b27435c8906 strace-4.5.15.tar.bz2 455607
+SHA256 ba8c492c1b2033d4e2131f05df9e3780d4bc35bea87aa32a6052dd53a814e288 strace-4.5.15.tar.bz2 455607
diff --git a/dev-util/strace/strace-4.5.15.ebuild b/dev-util/strace/strace-4.5.15.ebuild
new file mode 100644
index 000000000000..0f59d2d9f7fa
--- /dev/null
+++ b/dev-util/strace/strace-4.5.15.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.15.ebuild,v 1.1 2007/01/17 06:45:56 vapier Exp $
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static aio"
+
+DEPEND="aio? ( dev-libs/libaio )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #epatch "${FILESDIR}"/${PN}-4.5.11-fbsd.patch
+
+ # Fix SuperH support
+ epatch "${FILESDIR}"/strace-dont-use-REG_SYSCALL-for-sh.patch
+ epatch "${FILESDIR}"/${PN}-4.5.12-superh-update.patch
+
+ # Fix building on older ARM machines
+ epatch "${FILESDIR}"/strace-fix-arm-bad-syscall.patch
+
+ # Fix libaio support #103427
+ epatch "${FILESDIR}"/${PN}-4.5.12-libaio.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ filter-lfs-flags
+
+ use static && append-ldflags -static
+
+ econf $(use_enable aio libaio) || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog CREDITS NEWS PORTING README* TODO
+}