summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-07-07 00:50:16 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-07-07 00:50:16 +0000
commit691a26a748dce13eb5b701569d2c360fca850033 (patch)
tree34a563d618ad4de5447e7ebe2004094dc3f90e2f /dev-util
parentsync IUSE (-doc -gnome) (diff)
downloadhistorical-691a26a748dce13eb5b701569d2c360fca850033.tar.gz
historical-691a26a748dce13eb5b701569d2c360fca850033.tar.bz2
historical-691a26a748dce13eb5b701569d2c360fca850033.zip
New release: 0.20
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/monotone/ChangeLog7
-rw-r--r--dev-util/monotone/Manifest10
-rw-r--r--dev-util/monotone/files/digest-monotone-0.201
-rw-r--r--dev-util/monotone/monotone-0.20.ebuild69
4 files changed, 82 insertions, 5 deletions
diff --git a/dev-util/monotone/ChangeLog b/dev-util/monotone/ChangeLog
index 25ec8aa87615..d357c1316c92 100644
--- a/dev-util/monotone/ChangeLog
+++ b/dev-util/monotone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/monotone
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.15 2005/06/17 20:09:26 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.16 2005/07/07 00:50:16 leonardop Exp $
+
+*monotone-0.20 (06 Jul 2005)
+
+ 06 Jul 2005; Leonardo Boshell <leonardop@gentoo.org> monotone-0.20.ebuild:
+ New release.
17 Jun 2005; Michael Hanselmann <hansmi@gentoo.org> monotone-0.19.ebuild:
Stable on ppc.
diff --git a/dev-util/monotone/Manifest b/dev-util/monotone/Manifest
index 185382bbec03..5e2a47b22242 100644
--- a/dev-util/monotone/Manifest
+++ b/dev-util/monotone/Manifest
@@ -1,10 +1,12 @@
-MD5 790fb008dfdd0820a29a647565fe9284 monotone-0.17.ebuild 1692
+MD5 cf5e57960c881b5e4cee9e19765188f7 ChangeLog 2976
MD5 1e6a86b292ad8ea52efad1e28f593e2f metadata.xml 964
-MD5 0362b1f49b87c0959e11752087105c23 ChangeLog 2850
-MD5 aa7a28ac1380cf89fb5a1d0576a76707 monotone-0.18.ebuild 1687
MD5 dc5686ff5a40dfaf23bd7e7e2ae96073 monotone-0.16.ebuild 1236
+MD5 790fb008dfdd0820a29a647565fe9284 monotone-0.17.ebuild 1692
+MD5 aa7a28ac1380cf89fb5a1d0576a76707 monotone-0.18.ebuild 1687
MD5 af2251480135572c461c610665a18ab6 monotone-0.19.ebuild 1589
+MD5 b37e056f9865f7279561e83f3fe5c874 monotone-0.20.ebuild 1868
MD5 f7dab86750bae0e4ff09e2139b790084 files/digest-monotone-0.16 66
-MD5 da4fd1c22f053091a99f33b3da3331d3 files/digest-monotone-0.19 66
MD5 c8834d71dc37833961a7eb7b4a455e84 files/digest-monotone-0.17 66
MD5 a4899373e67a34bbd0127cfb616e19ae files/digest-monotone-0.18 66
+MD5 da4fd1c22f053091a99f33b3da3331d3 files/digest-monotone-0.19 66
+MD5 2a075cd7118d0bbc2e3ce1e41c97f0ee files/digest-monotone-0.20 66
diff --git a/dev-util/monotone/files/digest-monotone-0.20 b/dev-util/monotone/files/digest-monotone-0.20
new file mode 100644
index 000000000000..eb3033066d47
--- /dev/null
+++ b/dev-util/monotone/files/digest-monotone-0.20
@@ -0,0 +1 @@
+MD5 3bdf4da35ff576a401483815952f4045 monotone-0.20.tar.gz 4931957
diff --git a/dev-util/monotone/monotone-0.20.ebuild b/dev-util/monotone/monotone-0.20.ebuild
new file mode 100644
index 000000000000..63c8120b836b
--- /dev/null
+++ b/dev-util/monotone/monotone-0.20.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.20.ebuild,v 1.1 2005/07/07 00:50:16 leonardop Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Monotone Distributed Version Control System"
+HOMEPAGE="http://www.venge.net/monotone/"
+SRC_URI="http://www.venge.net/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="doc ipv6 nls"
+
+RDEPEND=">=dev-libs/boost-1.32"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3.2
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ doc? ( sys-apps/texinfo )"
+
+src_compile() {
+ local myconf="$(use_enable nls) $(use_enable ipv6)"
+
+ # more aggressive optimizations cause trouble with the crypto library
+ strip-flags
+ append-flags -fno-stack-protector-all -fno-stack-protector \
+ -fno-strict-aliasing
+
+ econf ${myconf} || die
+ emake || die "emake failed"
+ use doc && make html
+}
+
+src_test() {
+ make check || die "self test failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use doc
+ then
+ dohtml -r html/*
+ dohtml -r figures
+ fi
+
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README* UPGRADE
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If you are upgrading from:"
+ einfo " - 0.19 or earlier: there are some command line and server"
+ einfo " configuration changes; see /usr/share/doc/${PF}/NEWS.gz"
+ einfo " - 0.18 or earliear: if you have created a ~/.monotonerc, rename"
+ einfo " it to ~/.monotone/monotonerc, so monotone will still find it."
+ einfo " - 0.17: simply make a backup of your databases, just in case, and"
+ einfo " run \"db migrate\" on each."
+ einfo
+ einfo "For instructions to upgrade from previous versions, please read"
+ einfo "/usr/share/doc/${PF}/UPGRADE.gz"
+ einfo
+ einfo "Also, please note that 0.19 clients cannot talk to 0.20 servers,"
+ einfo "and vice-versa."
+ einfo
+}