summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-03-16 02:42:18 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-03-16 02:42:18 +0000
commit7c8cff30cb4b9050ace270c5f03aa77b69aa13ad (patch)
treeb4340e00f150f88e14a3b8473c9d62b7a99ec3e4 /dev-util
parentOut of date and broken build removed. (diff)
downloadhistorical-7c8cff30cb4b9050ace270c5f03aa77b69aa13ad.tar.gz
historical-7c8cff30cb4b9050ace270c5f03aa77b69aa13ad.tar.bz2
historical-7c8cff30cb4b9050ace270c5f03aa77b69aa13ad.zip
Initial revision of the package.
Boa constructor aims to be a GUI builder for wxPython a la Delphi.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/boa-constructor/ChangeLog9
-rw-r--r--dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild50
-rw-r--r--dev-util/boa-constructor/files/boa-constructor10
-rw-r--r--dev-util/boa-constructor/files/digest-boa-constructor-0.1.0_alpha1
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-util/boa-constructor/ChangeLog b/dev-util/boa-constructor/ChangeLog
new file mode 100644
index 000000000000..29c6c6a72e2c
--- /dev/null
+++ b/dev-util/boa-constructor/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/ChangeLog,v 1.1 2002/03/16 02:42:18 agenkin Exp $
+
+*boa-constructor-0.1.0_alpha (<Mar 15, 2002>)
+
+ 15 Mar 2002; Arcady Genkin <agenkin@thpoon.com> boa-constructor-0.1.0_alpha :
+
+ Initial version of the package. \ No newline at end of file
diff --git a/dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild b/dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild
new file mode 100644
index 000000000000..5c90375ce3a2
--- /dev/null
+++ b/dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Arcady Genkin <agenkin@thpoon.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/boa-constructor-0.1.0_alpha.ebuild,v 1.1 2002/03/16 02:42:18 agenkin Exp $
+
+DESCRIPTION="Python GUI RAD development tool."
+HOMEPAGE="http://boa-constructor.sourceforge.net/"
+
+BOA_VER=0.1.0-alpha
+SRC_URI="http://prdownloads.sourceforge.net/boa-constructor/${PN}-${BOA_VER}.src.zip"
+
+S="${WORKDIR}"/boa
+
+RDEPEND=">=dev-lang/python-2.0
+ >=dev-python/wxPython-2.3
+ dev-libs/expat"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_compile() {
+ python -c "import compileall; compileall.compile_dir('.', force=1)"
+}
+
+src_install () {
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+ local boadir="/usr/lib/python${pv}/site-packages/boa"
+
+ local dir
+ for dir in `find . -type d`
+ do
+ insinto "${boadir}/${dir}"
+ cd "${dir}"
+ local file
+ for file in *
+ do
+ [ -f "${file}" ] && doins "${file}"
+ done
+ cd "${S}"
+ done
+
+ insinto "${boadir}"
+ doins *.cfg
+ insinto "${boadir}/Plug-ins"
+ doins Plug-ins/*
+
+ dobin "${FILESDIR}/boa-constructor"
+
+ dodoc Bugs.txt Changes.txt Credits.txt PYTHONSTARTUP README.txt
+}
diff --git a/dev-util/boa-constructor/files/boa-constructor b/dev-util/boa-constructor/files/boa-constructor
new file mode 100644
index 000000000000..ce23f2bc4818
--- /dev/null
+++ b/dev-util/boa-constructor/files/boa-constructor
@@ -0,0 +1,10 @@
+#!/bin/sh
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/files/boa-constructor,v 1.1 2002/03/16 02:42:18 agenkin Exp $
+
+# This is a bit of a kludge, but works.
+# If anyone can think of a better way to start Boa, feel free to
+# modify.
+
+pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+cd /usr/lib/python"${pv}"/site-packages/boa
+exec /usr/bin/python Boa.pyc \ No newline at end of file
diff --git a/dev-util/boa-constructor/files/digest-boa-constructor-0.1.0_alpha b/dev-util/boa-constructor/files/digest-boa-constructor-0.1.0_alpha
new file mode 100644
index 000000000000..a5541e218d37
--- /dev/null
+++ b/dev-util/boa-constructor/files/digest-boa-constructor-0.1.0_alpha
@@ -0,0 +1 @@
+MD5 c8662a5a3570aab92954a43b55728e0c boa-constructor-0.1.0-alpha.src.zip 2338496