summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2003-04-19 23:56:43 +0000
committerBart Lauwers <blauwers@gentoo.org>2003-04-19 23:56:43 +0000
commit8f6344dfa733f2ede5f6c11d7b058b925d2214f4 (patch)
tree3d584c72eb1fad14243b8f9b9ceddb633bf5a65e /dev-util
parentRenamed virtual/virus -> virtual/antivirus (diff)
downloadhistorical-8f6344dfa733f2ede5f6c11d7b058b925d2214f4.tar.gz
historical-8f6344dfa733f2ede5f6c11d7b058b925d2214f4.tar.bz2
historical-8f6344dfa733f2ede5f6c11d7b058b925d2214f4.zip
Version bump per Bug#12640
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/boa-constructor/ChangeLog13
-rw-r--r--dev-util/boa-constructor/boa-constructor-0.2.3_alpha.ebuild51
-rw-r--r--dev-util/boa-constructor/files/digest-boa-constructor-0.2.3_alpha1
3 files changed, 61 insertions, 4 deletions
diff --git a/dev-util/boa-constructor/ChangeLog b/dev-util/boa-constructor/ChangeLog
index 5cbfa5232c5f..f5decd2f305e 100644
--- a/dev-util/boa-constructor/ChangeLog
+++ b/dev-util/boa-constructor/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for dev-util/boa-constructor
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/ChangeLog,v 1.5 2003/02/12 06:38:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/ChangeLog,v 1.6 2003/04/19 23:56:42 blauwers Exp $
+
+*boa-constructor-0.2.3_alpha (20 Apr 2003)
+
+ 20 Apr 2003; Bart Lauwers <blauwers@gentoo.org> :
+ Version bump per Bug#12640
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*boa-constructor-0.1.0_alpha (<Mar 15, 2002>)
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
15 Mar 2002; Arcady Genkin <agenkin@thpoon.com> boa-constructor-0.1.0_alpha :
- Initial version of the package. \ No newline at end of file
+ Initial version of the package.
diff --git a/dev-util/boa-constructor/boa-constructor-0.2.3_alpha.ebuild b/dev-util/boa-constructor/boa-constructor-0.2.3_alpha.ebuild
new file mode 100644
index 000000000000..5edf2752124f
--- /dev/null
+++ b/dev-util/boa-constructor/boa-constructor-0.2.3_alpha.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/boa-constructor-0.2.3_alpha.ebuild,v 1.1 2003/04/19 23:56:42 blauwers Exp $
+
+BOA=${P/_alpha/}
+S=${WORKDIR}/${BOA}
+DESCRIPTION="Python GUI RAD development tool."
+HOMEPAGE="http://boa-constructor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/boa-constructor/${BOA}.src.zip"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+RDEPEND=">=dev-lang/python-2.0
+ >=dev-python/wxPython-2.3
+ dev-libs/expat"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_compile() {
+ python -c "import compileall; compileall.compile_dir('.', force=1)"
+}
+
+src_install () {
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+ local boadir="/usr/lib/python${pv}/site-packages/boa"
+
+ local dir
+ for dir in `find . -type d`
+ do
+ insinto "${boadir}/${dir}"
+ cd "${dir}"
+ local file
+ for file in *
+ do
+ [ -f "${file}" ] && doins "${file}"
+ done
+ cd "${S}"
+ done
+
+ insinto "${boadir}"
+ doins *.cfg
+ insinto "${boadir}/Plug-ins"
+ doins Plug-ins/*
+
+ dobin "${FILESDIR}/boa-constructor"
+
+ dodoc Bugs.txt Changes.txt Credits.txt README.txt
+}
diff --git a/dev-util/boa-constructor/files/digest-boa-constructor-0.2.3_alpha b/dev-util/boa-constructor/files/digest-boa-constructor-0.2.3_alpha
new file mode 100644
index 000000000000..d0577ca245db
--- /dev/null
+++ b/dev-util/boa-constructor/files/digest-boa-constructor-0.2.3_alpha
@@ -0,0 +1 @@
+MD5 f111e10cd11c88a63cad7b1dc6449bff boa-constructor-0.2.3.src.zip 2464276