summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Silva <r3pek@gentoo.org>2005-09-19 14:45:46 +0000
committerCarlos Silva <r3pek@gentoo.org>2005-09-19 14:45:46 +0000
commita8bdb70762772f2d2fa5fc3c9c1ab0ef2c58ee06 (patch)
treed51e5f85b1b82a6ee7b5c7cdc1827c39b0fd7986 /dev-util
parentUpdated einfo about xpi handler (bug #106136) (diff)
downloadhistorical-a8bdb70762772f2d2fa5fc3c9c1ab0ef2c58ee06.tar.gz
historical-a8bdb70762772f2d2fa5fc3c9c1ab0ef2c58ee06.tar.bz2
historical-a8bdb70762772f2d2fa5fc3c9c1ab0ef2c58ee06.zip
Version bump
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/Manifest8
-rw-r--r--dev-util/git/files/digest-git-0.99.71
-rw-r--r--dev-util/git/git-0.99.7.ebuild68
4 files changed, 80 insertions, 4 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 4b7036aaa8a3..9b8f8888aecf 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.21 2005/09/18 14:19:38 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.22 2005/09/19 14:45:46 r3pek Exp $
+
+*git-0.99.7 (19 Sep 2005)
+
+ 19 Sep 2005; Carlos Silva <r3pek@gentoo.org> +git-0.99.7.ebuild:
+ Version bump
18 Sep 2005; Markus Rothe <corsair@gentoo.org> git-0.99.6.ebuild:
Added ~ppc64 (bug #106318)
diff --git a/dev-util/git/Manifest b/dev-util/git/Manifest
index d97decf8336a..8cb38083f6d3 100644
--- a/dev-util/git/Manifest
+++ b/dev-util/git/Manifest
@@ -1,6 +1,8 @@
-MD5 5606564f14b0bbcbfd142a659b8203d6 ChangeLog 2807
+MD5 4928be0d0eba18b62aa9321f89f363b1 git-0.99.7.ebuild 1742
MD5 edebd592261315b29a6b903b414573d2 git-0.7.ebuild 1312
-MD5 78c1b34edd1399c24d7d9e59212bc17a metadata.xml 221
MD5 9bbe3abc3061ff033cb32ccef8a86446 git-0.99.6.ebuild 1175
-MD5 8ebc37d29c321b95a3c0ae51ebee4d4d files/digest-git-0.7 59
+MD5 acb3dfd62f58653db2e03300e114501b ChangeLog 2915
+MD5 78c1b34edd1399c24d7d9e59212bc17a metadata.xml 221
MD5 c55b80b4ca5f800615642ce40266738f files/digest-git-0.99.6 68
+MD5 260308808ddefb27c238ed5a05ad8eee files/digest-git-0.99.7 68
+MD5 8ebc37d29c321b95a3c0ae51ebee4d4d files/digest-git-0.7 59
diff --git a/dev-util/git/files/digest-git-0.99.7 b/dev-util/git/files/digest-git-0.99.7
new file mode 100644
index 000000000000..71cfaf6ff94c
--- /dev/null
+++ b/dev-util/git/files/digest-git-0.99.7
@@ -0,0 +1 @@
+MD5 e5ce2803fc05897a173d9d15f7fb5df7 git-core-0.99.7.tar.bz2 347551
diff --git a/dev-util/git/git-0.99.7.ebuild b/dev-util/git/git-0.99.7.ebuild
new file mode 100644
index 000000000000..413ee786e5be
--- /dev/null
+++ b/dev-util/git/git-0.99.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-0.99.7.ebuild,v 1.1 2005/09/19 14:45:46 r3pek Exp $
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="http://kernel.org/pub/software/scm/git/${PN}-core-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mozsha1 ppcsha1 doc nocurl"
+S="${WORKDIR}/${PN}-core-${PV}"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !nocurl? ( net-misc/curl )
+ app-text/rcs
+ >=dev-util/cvsps-2.1
+ !app-misc/git
+ doc? ( >=app-text/asciidoc-7.0.1 app-text/xmlto )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:-g -O2:${CFLAGS}:" \
+ Makefile
+}
+
+src_compile() {
+ if use mozsha1; then
+ export MOZILLA_SHA1=yes
+ elif use ppcsha1; then
+ export PPC_SHA1=yes
+ elif use nocurl; then
+ export NO_CURL=yes
+ ewarn "git-http-pull will not be built because you are using the nocurl
+ use flag"
+ fi
+
+ make prefix=/usr || die "make failed"
+
+ if use doc; then
+ cd ${S}/Documentation
+ make || die "make documentation failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} prefix=/usr install || die "make install failed"
+ dodoc README COPYING
+
+ if use doc; then
+ doman Documentation/*.1 Documentation/*.7
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This version of GIT has changed some command names. It this version"
+ einfo "The old commands will still be present but linked to the new ones."
+ einfo "The future 0.99.8 version of GIT will NOT have this feature."
+ einfo
+ einfo "For the complete list of commands that got changed, visist:"
+ einfo "http://dev.gentoo.org/~r3pek/git-new-command-list.txt"
+ einfo
+}