summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2010-06-19 00:28:31 +0000
committerJonathan Callen <jcallen@gentoo.org>2010-06-19 00:28:31 +0000
commit27fa51bcc7e74ae492ed335552656b503a72d33b (patch)
tree8f97bfea59d6a9a3f4466021f1aba348360ef488 /dev-vcs/cvs2cl/cvs2cl-2.71.ebuild
parentMove package from dev-util/cvs to dev-vcs/cvs (diff)
downloadhistorical-27fa51bcc7e74ae492ed335552656b503a72d33b.tar.gz
historical-27fa51bcc7e74ae492ed335552656b503a72d33b.tar.bz2
historical-27fa51bcc7e74ae492ed335552656b503a72d33b.zip
Move package from dev-util/cvs2cl to dev-vcs/cvs2cl
Package-Manager: portage-2.2_rc67/cvs/Linux i686 RepoMan-Options: --force
Diffstat (limited to 'dev-vcs/cvs2cl/cvs2cl-2.71.ebuild')
-rw-r--r--dev-vcs/cvs2cl/cvs2cl-2.71.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-vcs/cvs2cl/cvs2cl-2.71.ebuild b/dev-vcs/cvs2cl/cvs2cl-2.71.ebuild
new file mode 100644
index 000000000000..33398b973dff
--- /dev/null
+++ b/dev-vcs/cvs2cl/cvs2cl-2.71.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2cl/cvs2cl-2.71.ebuild,v 1.1 2010/06/19 00:28:31 abcd Exp $
+
+DESCRIPTION="produces a GNU-style ChangeLog for CVS-controlled sources"
+HOMEPAGE="http://www.red-bean.com/cvs2cl/"
+SRC_URI="mirror://gentoo/${P}.pl.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+S=${WORKDIR}
+
+maint_pkg_create() {
+ set -x
+ wget http://www.red-bean.com/cvs2cl/${PN}.pl
+ mv ${PN}.pl ${P}.pl
+ bzip2 ${P}.pl
+ ls -l ${PWD}/${P}.pl.bz2
+ set +x
+}
+#pkg_setup() { maint_pkg_create; }
+
+src_install() {
+ newbin ${P}.pl ${PN} || die
+}