summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-16 12:24:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-16 12:24:09 +0000
commit1986833067bc75f768c847aee303306697a4b53d (patch)
tree6e0bf6ed7d5b51a9b68582b5f0f03e635d595b6c /eclass/cmake-utils.eclass
parentAdd udev useflag (diff)
downloadhistorical-1986833067bc75f768c847aee303306697a4b53d.tar.gz
historical-1986833067bc75f768c847aee303306697a4b53d.tar.bz2
historical-1986833067bc75f768c847aee303306697a4b53d.zip
export XDG_CONFIG_HOME to temp. directory for sandbox
Diffstat (limited to 'eclass/cmake-utils.eclass')
-rw-r--r--eclass/cmake-utils.eclass4
1 files changed, 3 insertions, 1 deletions
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index f323ac60097f..718ef64375a1 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/cmake-utils.eclass,v 1.30 2009/08/08 20:08:02 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/cmake-utils.eclass,v 1.31 2009/10/16 12:24:09 ssuominen Exp $
# @ECLASS: cmake-utils.eclass
# @MAINTAINER:
@@ -244,6 +244,8 @@ Install path: ${CMAKE_INSTALL_PREFIX}\n")' >> CMakeLists.txt
# General function for configuring with cmake. Default behaviour is to start an
# out-of-source build.
cmake-utils_src_configure() {
+ export XDG_CONFIG_HOME="${T}"
+
debug-print-function ${FUNCNAME} "$@"
_check_build_dir init